summaryrefslogtreecommitdiff
path: root/packages/gcc
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-06-05 09:03:32 +0000
committerKoen Kooi <koen@openembedded.org>2008-06-05 09:03:32 +0000
commitbba12610e192611bf833c998ccc865c01c67fba7 (patch)
treec9a60e1ee5a4ede590f2c3f39cbe4fce5dde98c4 /packages/gcc
parentac7ea32e5476f4bd9124563754b013f21cc1507e (diff)
gcc* 4.3.0: --enable-cheaders=c_std
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/gcc-4.3.0.inc2
-rw-r--r--packages/gcc/gcc-cross_4.3.0.bb8
2 files changed, 8 insertions, 2 deletions
diff --git a/packages/gcc/gcc-4.3.0.inc b/packages/gcc/gcc-4.3.0.inc
index b5ab13f1b4..f0aac4ca78 100644
--- a/packages/gcc/gcc-4.3.0.inc
+++ b/packages/gcc/gcc-4.3.0.inc
@@ -68,5 +68,5 @@ SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
FORTRAN = ""
JAVA = ""
-EXTRA_OECONF_BASE = " --enable-libssp --disable-bootstrap --disable-libgomp --disable-libmudflap"
+EXTRA_OECONF_BASE = " --enable-cheaders=c_std --enable-libssp --disable-bootstrap --disable-libgomp --disable-libmudflap"
diff --git a/packages/gcc/gcc-cross_4.3.0.bb b/packages/gcc/gcc-cross_4.3.0.bb
index 72f72835c3..382a234816 100644
--- a/packages/gcc/gcc-cross_4.3.0.bb
+++ b/packages/gcc/gcc-cross_4.3.0.bb
@@ -7,6 +7,12 @@ require gcc-package-cross.inc
SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
-EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"
+EXTRA_OECONF += " --enable-cheaders=c_std --disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"
+
+# Hack till we fix *libc properly
+do_stage_append() {
+ ln -sf ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include/
+}
+
ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${layout_includedir}"