summaryrefslogtreecommitdiff
path: root/packages/gcc
diff options
context:
space:
mode:
authorCliff Brake <cbrake@bec-systems.com>2006-11-13 18:57:30 +0000
committerCliff Brake <cbrake@bec-systems.com>2006-11-13 18:57:30 +0000
commit40951de5f883d7a2d9d5445a9b73c3424ee245f1 (patch)
tree6a9d8dfe2fef258e9dd8b079c3517b0c1edbfbe6 /packages/gcc
parent1c9e8b7ced097812f43cdd5782023464cef09ed8 (diff)
parente2e9b0ab1d6af8ec246cef0f9d848083dff2b8e0 (diff)
merge of '9ebe19c38b13611632684c440b048e45471bf916'
and 'e0d42dfa54011bb501a5a723ec0554c757bfc933'
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/gcc-fpu.inc6
-rw-r--r--packages/gcc/gcc3-build.inc5
-rw-r--r--packages/gcc/gcc_3.3.3.bb5
-rw-r--r--packages/gcc/gcc_3.3.4.bb5
-rw-r--r--packages/gcc/gcc_4.1.1.bb3
5 files changed, 11 insertions, 13 deletions
diff --git a/packages/gcc/gcc-fpu.inc b/packages/gcc/gcc-fpu.inc
new file mode 100644
index 0000000000..bb03d95567
--- /dev/null
+++ b/packages/gcc/gcc-fpu.inc
@@ -0,0 +1,6 @@
+
+def get_gcc_fpu_setting(bb, d):
+ if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
+ return "--with-float=soft"
+ return ""
+
diff --git a/packages/gcc/gcc3-build.inc b/packages/gcc/gcc3-build.inc
index 6260a51533..2924f0f9dd 100644
--- a/packages/gcc/gcc3-build.inc
+++ b/packages/gcc/gcc3-build.inc
@@ -54,10 +54,7 @@ ARCH_FLAGS_FOR_TARGET_slugos = "${TARGET_CC_ARCH}"
ARCH_FLAGS_FOR_TARGET_unslung = "${TARGET_CC_ARCH}"
EXTRA_OEMAKE += "ARCH_FLAGS_FOR_TARGET='${ARCH_FLAGS_FOR_TARGET}'"
-def get_gcc_fpu_setting(bb, d):
- if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
- return "--with-float=soft"
- return ""
+require gcc-fpu.inc
python __anonymous () {
import bb, re
diff --git a/packages/gcc/gcc_3.3.3.bb b/packages/gcc/gcc_3.3.3.bb
index 8852f81def..0c237a9166 100644
--- a/packages/gcc/gcc_3.3.3.bb
+++ b/packages/gcc/gcc_3.3.3.bb
@@ -124,10 +124,7 @@ EXTRA_OECONF_uclibc = "--disable-__cxa_atexit"
EXTRA_OECONF_glibc = "--enable-__cxa_atexit"
EXTRA_OECONF += "${@get_gcc_fpu_setting(bb, d)}"
-def get_gcc_fpu_setting(bb, d):
- if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
- return "--with-float=soft"
- return ""
+require gcc-fpu.inc
python __anonymous () {
import bb, re
diff --git a/packages/gcc/gcc_3.3.4.bb b/packages/gcc/gcc_3.3.4.bb
index 49f14cd888..bb52fa6a1f 100644
--- a/packages/gcc/gcc_3.3.4.bb
+++ b/packages/gcc/gcc_3.3.4.bb
@@ -103,10 +103,7 @@ EXTRA_OECONF_uclibc = "--disable-__cxa_atexit"
EXTRA_OECONF_glibc = "--enable-__cxa_atexit"
EXTRA_OECONF += "${@get_gcc_fpu_setting(bb, d)}"
-def get_gcc_fpu_setting(bb, d):
- if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
- return "--with-float=soft"
- return ""
+require gcc-fpu.inc
python __anonymous () {
import bb, re
diff --git a/packages/gcc/gcc_4.1.1.bb b/packages/gcc/gcc_4.1.1.bb
index cd93cab7e2..9c0bd7baac 100644
--- a/packages/gcc/gcc_4.1.1.bb
+++ b/packages/gcc/gcc_4.1.1.bb
@@ -34,6 +34,7 @@ SRC_URI = "http://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.1/gcc-4.1.1.tar.bz2 \
SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
#Set the fortran bits
+# 'fortran' or '', not 'f77' like gcc3 had
FORTRAN = ""
HAS_GFORTRAN = "no"
HAS_G2C = "no"
@@ -41,7 +42,7 @@ HAS_G2C = "no"
#Set the java bits
JAVA_arm = ""
-LANGUAGES = "c,c++"
+LANGUAGES = "c,c++${FORTRAN}${JAVA}"
require gcc3-build.inc