summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-cross_csl-arm.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/gcc/gcc-cross_csl-arm.bb
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/gcc/gcc-cross_csl-arm.bb')
-rw-r--r--packages/gcc/gcc-cross_csl-arm.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/packages/gcc/gcc-cross_csl-arm.bb b/packages/gcc/gcc-cross_csl-arm.bb
index e69de29bb2..3be3c603a5 100644
--- a/packages/gcc/gcc-cross_csl-arm.bb
+++ b/packages/gcc/gcc-cross_csl-arm.bb
@@ -0,0 +1,15 @@
+include gcc_csl-arm.bb
+# path mangling, needed by the cross packaging
+include gcc-paths-cross.inc
+inherit cross
+# NOTE: split PR. If the main .oe changes something that affects its *build*
+# remember to increment this one too.
+PR = "r0"
+
+DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc"
+PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
+
+# cross build
+include gcc3-cross-build.inc
+# cross packaging
+include gcc-package-cross.inc