summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-cross_3.3.3.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2008-03-16 00:34:24 +0000
committerRichard Purdie <rpurdie@rpsys.net>2008-03-16 00:34:24 +0000
commitfab7419cc6a2e53d1cc122abb6d8a3ce0e46fd07 (patch)
treed6e97778e54a971bb9d6334187202af54653c553 /packages/gcc/gcc-cross_3.3.3.bb
parent9d362ff9245347ab553cb7d47495b496cbb6ba1d (diff)
gcc: Move old style gcc*build*.inc includes into gcc-configure-{target|cross|sdk} and a common include file. Factor some common data not related to configure into gcc-common.inc. Rewrite 3.3.3 and 3.3.4 recipes to use standard includes (tested and they work).
Diffstat (limited to 'packages/gcc/gcc-cross_3.3.3.bb')
-rw-r--r--packages/gcc/gcc-cross_3.3.3.bb51
1 files changed, 1 insertions, 50 deletions
diff --git a/packages/gcc/gcc-cross_3.3.3.bb b/packages/gcc/gcc-cross_3.3.3.bb
index b64756246c..c3a4daa359 100644
--- a/packages/gcc/gcc-cross_3.3.3.bb
+++ b/packages/gcc/gcc-cross_3.3.3.bb
@@ -2,55 +2,6 @@ PR = "r3"
require gcc-${PV}.inc
require gcc-cross.inc
+require gcc-configure-cross.inc
require gcc-package-cross.inc
-EXTRA_OECONF_PATHS = "--with-local-prefix=${CROSS_DIR}/${TARGET_SYS} \
- --with-gxx-include-dir=${CROSS_DIR}/${TARGET_SYS}/include/c++"
-
-export CPPFLAGS = ""
-export CXXFLAGS = ""
-export CFLAGS = ""
-export LDFLAGS = ""
-
-do_configure () {
- export CC="${BUILD_CC}"
- export AR="${TARGET_SYS}-ar"
- export RANLIB="${TARGET_SYS}-ranlib"
- export LD="${TARGET_SYS}-ld"
- export NM="${TARGET_SYS}-nm"
- rm -f ${CROSS_DIR}/lib/gcc-lib/${TARGET_SYS}/${PV}/libgcc_eh.a
- (cd ${S} && gnu-configize) || die "failure running gnu-configize"
- oe_runconf
-}
-
-do_compile_prepend () {
- export CC="${BUILD_CC}"
- export AR_FOR_TARGET="${TARGET_SYS}-ar"
- export RANLIB_FOR_TARGET="${TARGET_SYS}-ranlib"
- export LD_FOR_TARGET="${TARGET_SYS}-ld"
- export NM_FOR_TARGET="${TARGET_SYS}-nm"
- export CC_FOR_TARGET="${CCACHE} ${TARGET_SYS}-gcc"
-}
-
-do_stage_append () {
- for d in info man share/doc share/locale ; do
- rm -rf ${CROSS_DIR}/$d
- done
-
- # Fix a few include links so cross builds are happier
- if [ ! -e ${STAGING_INCDIR}/c++ ]; then
- mkdir -p ${STAGING_INCDIR}
- rm -f ${STAGING_INCDIR}/c++
- ln -sf ${CROSS_DIR}/${TARGET_SYS}/include/c++ \
- ${STAGING_INCDIR}/
- fi
-
- # We use libiberty from binutils
- rm -f ${CROSS_DIR}/lib/libiberty.a
-
- # We probably don't need these
- rmdir ${CROSS_DIR}/include || :
-
- # We don't really need to keep this around
- rm -rf ${CROSS_DIR}/share
-}