summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-cross-intermediate_4.3.2.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-08-28 08:11:21 +0000
committerKoen Kooi <koen@openembedded.org>2008-08-28 08:11:21 +0000
commit36508f4088546d49972d1eda016dfd616de43a46 (patch)
tree2bceae4502ba26f454e6e9e2beafb2b9319567bd /packages/gcc/gcc-cross-intermediate_4.3.2.bb
parent80cc287288dcefc1a373d6ebd63bd31c6433420a (diff)
gcc* 4.3.2: add skeleton, it is missing sysroot, xgcc and uclibc patches
Diffstat (limited to 'packages/gcc/gcc-cross-intermediate_4.3.2.bb')
-rw-r--r--packages/gcc/gcc-cross-intermediate_4.3.2.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/packages/gcc/gcc-cross-intermediate_4.3.2.bb b/packages/gcc/gcc-cross-intermediate_4.3.2.bb
new file mode 100644
index 0000000000..b0932f520d
--- /dev/null
+++ b/packages/gcc/gcc-cross-intermediate_4.3.2.bb
@@ -0,0 +1,14 @@
+require gcc-cross_${PV}.bb
+require gcc-cross-intermediate.inc
+
+DEPENDS += "gmp-native mpfr-native"
+
+EXTRA_OECONF += " --disable-libmudflap \
+ --disable-libgomp \
+ --disable-libssp"
+
+# Hack till we fix *libc properly
+do_stage_append() {
+ ln -sf ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include/
+}
+