summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-4.3.2/fortran-cross-compile-hack.patch
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-08-28 08:11:21 +0000
committerKoen Kooi <koen@openembedded.org>2008-08-28 08:11:21 +0000
commit36508f4088546d49972d1eda016dfd616de43a46 (patch)
tree2bceae4502ba26f454e6e9e2beafb2b9319567bd /packages/gcc/gcc-4.3.2/fortran-cross-compile-hack.patch
parent80cc287288dcefc1a373d6ebd63bd31c6433420a (diff)
gcc* 4.3.2: add skeleton, it is missing sysroot, xgcc and uclibc patches
Diffstat (limited to 'packages/gcc/gcc-4.3.2/fortran-cross-compile-hack.patch')
-rw-r--r--packages/gcc/gcc-4.3.2/fortran-cross-compile-hack.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/gcc/gcc-4.3.2/fortran-cross-compile-hack.patch b/packages/gcc/gcc-4.3.2/fortran-cross-compile-hack.patch
new file mode 100644
index 0000000000..b3d38ad983
--- /dev/null
+++ b/packages/gcc/gcc-4.3.2/fortran-cross-compile-hack.patch
@@ -0,0 +1,30 @@
+* Fortran would have searched for arm-angstrom-gnueabi-gfortran but would have used
+ used gfortan. For gcc_4.2.2.bb we want to use the gfortran compiler from our cross
+ directory.
+
+diff --git a/libgfortran/configure b/libgfortran/configure
+index f7d86fb..d0966ec 100755
+--- a/libgfortran/configure
++++ b/libgfortran/configure
+@@ -4475,6 +4475,6 @@ exec 5>>./config.log
+
+ # We need gfortran to compile parts of the library
+ #AC_PROG_FC(gfortran)
+-FC="$GFORTRAN"
++#FC="$GFORTRAN"
+ ac_ext=${FC_SRCEXT-f}
+ ac_compile='$FC -c $FCFLAGS $FCFLAGS_SRCEXT conftest.$ac_ext >&5'
+\ No newline at end of file
+diff --git a/libgfortran/configure.ac b/libgfortran/configure.ac
+index 4661306..9f83e55 100644
+--- a/libgfortran/configure.ac
++++ b/libgfortran/configure.ac
+@@ -140,7 +140,7 @@ AC_SUBST(enable_static)
+
+ # We need gfortran to compile parts of the library
+ #AC_PROG_FC(gfortran)
+-FC="$GFORTRAN"
++#FC="$GFORTRAN"
+ AC_PROG_FC(gfortran)
+
+ # extra LD Flags which are required for targets