summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-4.3.2/debian/libssp-gnu.dpatch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/gcc/gcc-4.3.2/debian/libssp-gnu.dpatch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/gcc/gcc-4.3.2/debian/libssp-gnu.dpatch')
-rw-r--r--packages/gcc/gcc-4.3.2/debian/libssp-gnu.dpatch52
1 files changed, 0 insertions, 52 deletions
diff --git a/packages/gcc/gcc-4.3.2/debian/libssp-gnu.dpatch b/packages/gcc/gcc-4.3.2/debian/libssp-gnu.dpatch
deleted file mode 100644
index a0c6acd9fc..0000000000
--- a/packages/gcc/gcc-4.3.2/debian/libssp-gnu.dpatch
+++ /dev/null
@@ -1,52 +0,0 @@
-#! /bin/sh -e
-
-# DP: GNU/k*BSD support
-# Author: Aurelien Jarno <aurel32@debian.org>
-# Status: Submitted: http://gcc.gnu.org/ml/gcc-patches/2007-04/msg01962.html
-
-dir=
-if [ $# -eq 3 -a "$2" = '-d' ]; then
- pdir="-d $3"
- dir="$3/"
-elif [ $# -ne 1 ]; then
- echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
- exit 1
-fi
-case "$1" in
- -patch)
- patch $pdir -f --no-backup-if-mismatch -p1 < $0
- ;;
- -unpatch)
- patch $pdir -f --no-backup-if-mismatch -R -p1 < $0
- ;;
- *)
- echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
- exit 1
-esac
-exit 0
-
-# append the patch here and adjust the -p? flag in the patch calls.
-
---- src.orig/gcc/configure 2008-03-01 15:51:06 +0100
-+++ src/gcc/configure 2008-03-01 16:02:24 +0100
-@@ -17110,7 +17110,7 @@
- else
- gcc_cv_libc_provides_ssp=no
- case "$target" in
-- *-*-linux*)
-+ *-*-*-gnu*)
- if test x$host != x$target || test "x$TARGET_SYSTEM_ROOT" != x; then
- if test "x$with_sysroot" = x; then
- glibc_header_dir="${exec_prefix}/${target_noncanonical}/sys-include"
---- src.orig/gcc/configure.ac 2008-02-01 19:55:55 +0100
-+++ src/gcc/configure.ac 2008-03-01 16:02:06 +0100
-@@ -3379,7 +3379,7 @@
- gcc_cv_libc_provides_ssp,
- [gcc_cv_libc_provides_ssp=no
- case "$target" in
-- *-*-linux*)
-+ *-*-*-gnu*)
- if test x$host != x$target || test "x$TARGET_SYSTEM_ROOT" != x; then
- if test "x$with_sysroot" = x; then
- glibc_header_dir="${exec_prefix}/${target_noncanonical}/sys-include"
-