summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-4.2.4/fortran-cross-compile-hack.patch
diff options
context:
space:
mode:
authorOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2008-06-03 11:41:30 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2008-06-03 11:41:30 +0000
commit972f72f4e47196817b8a3fc62a9e9dd188490f81 (patch)
tree77d115be3d0a03cf9b86de1a70d30330e4d236dc /packages/gcc/gcc-4.2.4/fortran-cross-compile-hack.patch
parentb4db5d7f3e1a0470f2111508e2b701acee95055e (diff)
parent915c1e3654c4be1667a9390c3671d1a3601e2a56 (diff)
merge of '6c9b3832ef2260eb1b3a74e74b1d73166ab79d89'
and 'f275c97e2c93f0e846205b213e997b28ed0b148e'
Diffstat (limited to 'packages/gcc/gcc-4.2.4/fortran-cross-compile-hack.patch')
-rw-r--r--packages/gcc/gcc-4.2.4/fortran-cross-compile-hack.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/gcc/gcc-4.2.4/fortran-cross-compile-hack.patch b/packages/gcc/gcc-4.2.4/fortran-cross-compile-hack.patch
new file mode 100644
index 0000000000..b3d38ad983
--- /dev/null
+++ b/packages/gcc/gcc-4.2.4/fortran-cross-compile-hack.patch
@@ -0,0 +1,30 @@
+* Fortran would have searched for arm-angstrom-gnueabi-gfortran but would have used
+ used gfortan. For gcc_4.2.2.bb we want to use the gfortran compiler from our cross
+ directory.
+
+diff --git a/libgfortran/configure b/libgfortran/configure
+index f7d86fb..d0966ec 100755
+--- a/libgfortran/configure
++++ b/libgfortran/configure
+@@ -4475,6 +4475,6 @@ exec 5>>./config.log
+
+ # We need gfortran to compile parts of the library
+ #AC_PROG_FC(gfortran)
+-FC="$GFORTRAN"
++#FC="$GFORTRAN"
+ ac_ext=${FC_SRCEXT-f}
+ ac_compile='$FC -c $FCFLAGS $FCFLAGS_SRCEXT conftest.$ac_ext >&5'
+\ No newline at end of file
+diff --git a/libgfortran/configure.ac b/libgfortran/configure.ac
+index 4661306..9f83e55 100644
+--- a/libgfortran/configure.ac
++++ b/libgfortran/configure.ac
+@@ -140,7 +140,7 @@ AC_SUBST(enable_static)
+
+ # We need gfortran to compile parts of the library
+ #AC_PROG_FC(gfortran)
+-FC="$GFORTRAN"
++#FC="$GFORTRAN"
+ AC_PROG_FC(gfortran)
+
+ # extra LD Flags which are required for targets