summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-4.2.2/fortran-cross-compile-hack.patch
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2008-01-21 21:09:09 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2008-01-21 21:09:09 +0000
commitafd58cdcce656ced784bfca78d7d96e2edca8cee (patch)
treeb49291fedc042760b35f74afa9b7e82b591147e5 /packages/gcc/gcc-4.2.2/fortran-cross-compile-hack.patch
parentac6de0f3c0d8d5fe5708d9125c1319fbf5d627a6 (diff)
parenta7a4c7d6f9bbcda53d3bf07d51142d41e1a4558b (diff)
merge of '1cc9d40e03f431fac4150580f6a58521cae55509'
and 'a250ef0b1707ead866fe051ca88c56e538d51bfb'
Diffstat (limited to 'packages/gcc/gcc-4.2.2/fortran-cross-compile-hack.patch')
-rw-r--r--packages/gcc/gcc-4.2.2/fortran-cross-compile-hack.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/gcc/gcc-4.2.2/fortran-cross-compile-hack.patch b/packages/gcc/gcc-4.2.2/fortran-cross-compile-hack.patch
new file mode 100644
index 0000000000..b3d38ad983
--- /dev/null
+++ b/packages/gcc/gcc-4.2.2/fortran-cross-compile-hack.patch
@@ -0,0 +1,30 @@
+* Fortran would have searched for arm-angstrom-gnueabi-gfortran but would have used
+ used gfortan. For gcc_4.2.2.bb we want to use the gfortran compiler from our cross
+ directory.
+
+diff --git a/libgfortran/configure b/libgfortran/configure
+index f7d86fb..d0966ec 100755
+--- a/libgfortran/configure
++++ b/libgfortran/configure
+@@ -4475,6 +4475,6 @@ exec 5>>./config.log
+
+ # We need gfortran to compile parts of the library
+ #AC_PROG_FC(gfortran)
+-FC="$GFORTRAN"
++#FC="$GFORTRAN"
+ ac_ext=${FC_SRCEXT-f}
+ ac_compile='$FC -c $FCFLAGS $FCFLAGS_SRCEXT conftest.$ac_ext >&5'
+\ No newline at end of file
+diff --git a/libgfortran/configure.ac b/libgfortran/configure.ac
+index 4661306..9f83e55 100644
+--- a/libgfortran/configure.ac
++++ b/libgfortran/configure.ac
+@@ -140,7 +140,7 @@ AC_SUBST(enable_static)
+
+ # We need gfortran to compile parts of the library
+ #AC_PROG_FC(gfortran)
+-FC="$GFORTRAN"
++#FC="$GFORTRAN"
+ AC_PROG_FC(gfortran)
+
+ # extra LD Flags which are required for targets