summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-3.4.6
diff options
context:
space:
mode:
authorwoglinde <heinold@inf.fu-berlin.de>2008-11-02 18:34:21 +0100
committerwoglinde <heinold@inf.fu-berlin.de>2008-11-02 18:34:21 +0100
commit8b2452efc012786d33b4b1d702e2c7c593aecc7c (patch)
treefa24443a328dcb9185b4b1ae3cdbe2a62c171197 /packages/gcc/gcc-3.4.6
parentae5d55503ac7adc9aa307504486de7a143d1bfbe (diff)
gcc: fix open() with O_CREATE for version 3.4.3 and 3.4.6
* on ubuntu the compiler starting with intreprid yells at using open() with O_CREATE and not settinge a proper filecreationmask * closes bug 4626 reported by Vladimir Bondar with a modified patch * bump PR on all .bb which are needing it
Diffstat (limited to 'packages/gcc/gcc-3.4.6')
-rw-r--r--packages/gcc/gcc-3.4.6/gcc-posix.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/packages/gcc/gcc-3.4.6/gcc-posix.patch b/packages/gcc/gcc-3.4.6/gcc-posix.patch
new file mode 100644
index 0000000000..99f813e866
--- /dev/null
+++ b/packages/gcc/gcc-3.4.6/gcc-posix.patch
@@ -0,0 +1,11 @@
+--- gcc-3.4.6/gcc/collect2.c 2008-10-04 18:17:17.796750393 +0400
++++ gcc-3.4.6/gcc/collect2.new 2008-10-04 18:24:10.120748711 +0400
+@@ -1534,7 +1534,7 @@ collect_execute (const char *prog, char
+ if (redir)
+ {
+ /* Open response file. */
+- redir_handle = open (redir, O_WRONLY | O_TRUNC | O_CREAT);
++ redir_handle = open (redir, O_WRONLY | O_TRUNC | O_CREAT, S_IWUSR);
+
+ /* Duplicate the stdout and stderr file handles
+ so they can be restored later. */