summaryrefslogtreecommitdiff
path: root/packages/gaim/pidgin
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-05-08 17:17:40 +0000
committerKoen Kooi <koen@openembedded.org>2007-05-08 17:17:40 +0000
commit12e67884da766a69ee3b46f908da105a1c92187a (patch)
tree723383be63e2793a2a7f02fee14eb0beadaed949 /packages/gaim/pidgin
parentcfc067b7935b039556c6867710889ca726d8e908 (diff)
pidgin: add first stab at a 2.0.0 recipes
Known defects: ls image/usr/lib/purple-2/ libjabber.so libjabber.so.0 libjabber.so.0.0.0 liboscar.so liboscar.so.0 liboscar.so.0.0.0 log_reader.so The jabber and oscor protocol don't get packaged because do_split_packages doesn't do symlinks. Since I don't know whether pidgin scans for *.so or lib* on startup I haven't packaged these. Improvements welcome
Diffstat (limited to 'packages/gaim/pidgin')
-rw-r--r--packages/gaim/pidgin/.mtn2git_empty0
-rw-r--r--packages/gaim/pidgin/gconf-no-errors.patch12
-rw-r--r--packages/gaim/pidgin/sanitize-configure.ac.patch33
3 files changed, 45 insertions, 0 deletions
diff --git a/packages/gaim/pidgin/.mtn2git_empty b/packages/gaim/pidgin/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gaim/pidgin/.mtn2git_empty
diff --git a/packages/gaim/pidgin/gconf-no-errors.patch b/packages/gaim/pidgin/gconf-no-errors.patch
new file mode 100644
index 0000000000..9a95175ac9
--- /dev/null
+++ b/packages/gaim/pidgin/gconf-no-errors.patch
@@ -0,0 +1,12 @@
+--- /tmp/Makefile.am 2007-05-08 18:39:49.000000000 +0200
++++ pidgin-2.0.0/libpurple/gconf/Makefile.am 2007-05-08 18:40:13.755251000 +0200
+@@ -8,8 +8,7 @@
+
+ if GCONF_SCHEMAS_INSTALL
+ install-data-local:
+- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(schema_DATA) 2>&1 | \
+- grep -v "^WARNING: failed to install schema" | grep -v "^Attached schema" 1>&2
++ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(schema_DATA) 2>&1
+ else
+ install-data-local:
+ endif
diff --git a/packages/gaim/pidgin/sanitize-configure.ac.patch b/packages/gaim/pidgin/sanitize-configure.ac.patch
new file mode 100644
index 0000000000..a77d64f40b
--- /dev/null
+++ b/packages/gaim/pidgin/sanitize-configure.ac.patch
@@ -0,0 +1,33 @@
+--- /tmp/configure.ac 2007-05-08 17:29:02.000000000 +0200
++++ pidgin-2.0.0/configure.ac 2007-05-08 17:30:30.325251000 +0200
+@@ -472,7 +472,7 @@
+ if test "x$enable_consoleui" = "xyes"; then
+ dnl # Some distros put the headers in ncursesw/, some don't
+ found_ncurses_h=no
+- for location in $ac_ncurses_includes $NCURSES_HEADERS /usr/include/ncursesw /usr/include
++ for location in $ac_ncurses_includes $NCURSES_HEADERS
+ do
+ f="$location/ncurses.h"
+ AC_CHECK_HEADER($f,[
+@@ -1860,10 +1860,6 @@
+ KRB4_CFLAGS="$KRB4_CFLAGS -I${kerberos}/include/kerberosIV"
+ fi
+ KRB4_LDFLAGS="-L${kerberos}/lib"
+- elif test -d /usr/local/include/kerberosIV ; then
+- KRB4_CFLAGS="-I/usr/local/include/kerberosIV"
+- elif test -d /usr/include/kerberosIV ; then
+- KRB4_CFLAGS="-I/usr/include/kerberosIV"
+ fi
+ AC_DEFINE(ZEPHYR_USES_KERBEROS, 1, [Define if kerberos should be used in Zephyr.])
+
+@@ -1896,10 +1892,6 @@
+ ZEPHYR_LDFLAGS="-L${zephyr}/lib"
+ elif test -d /usr/athena/include/zephyr ; then
+ ZEPHYR_CFLAGS="-I/usr/athena/include"
+- elif test -d /usr/include/zephyr ; then
+- ZEPHYR_CFLAGS="-I/usr/include"
+- elif test -d /usr/local/include/zephyr ; then
+- ZEPHYR_CFLAGS="-I/usr/local/include"
+ fi
+ AC_DEFINE(LIBZEPHYR_EXT, 1 , [Define if external libzephyr should be used.])
+ AM_CONDITIONAL(EXTERNAL_LIBZEPHYR, test "x$zephyr" != "xno")