summaryrefslogtreecommitdiff
path: root/packages/ftpd-topfield/ftpd-topfield_0.6.10.bb
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2006-09-24 19:19:44 +0000
committerRod Whitby <rod@whitby.id.au>2006-09-24 19:19:44 +0000
commitf8e11cb4f973830bf326d6f2a47d2a4220d0b9b5 (patch)
treec10867ab24725eece791b1e8110568fe74812ea6 /packages/ftpd-topfield/ftpd-topfield_0.6.10.bb
parentc2ea72d6e94e4658eeabaca413ebfb2a542d8088 (diff)
ftpd-topfield: Update to latest version.
Diffstat (limited to 'packages/ftpd-topfield/ftpd-topfield_0.6.10.bb')
-rwxr-xr-xpackages/ftpd-topfield/ftpd-topfield_0.6.10.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/ftpd-topfield/ftpd-topfield_0.6.10.bb b/packages/ftpd-topfield/ftpd-topfield_0.6.10.bb
new file mode 100755
index 0000000000..2e63347f18
--- /dev/null
+++ b/packages/ftpd-topfield/ftpd-topfield_0.6.10.bb
@@ -0,0 +1,35 @@
+# This package builds the ftpd-topfield program
+PR = "r0"
+DESCRIPTION = "ftpd-topfield - FTP access to TopField PVR"
+HOMEPAGE = "http://sourceforge.net/projects/puppy"
+MAINTAINER = "NSLU2 Linux <www.nslu2-linux.org>"
+SECTION = "net"
+LICENSE = "MIT"
+
+SRC_URI = "cvs://anonymous@puppy.cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=ftpd-topfield;tag=FTPD_TOPFIELD_0_6_10 \
+ cvs://anonymous@puppy.cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=libtopfield;tag=FTPD_TOPFIELD_0_6_10 \
+ file://init"
+
+# The source will end up in the subdirectory 'ftpd-topfield' - no release name
+S = "${WORKDIR}/ftpd-topfield"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "ftpd-topfield"
+INITSCRIPT_PARAMS = "defaults"
+
+# Just the one package at present
+PACKAGES = "${PN}"
+
+inherit autotools
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 ${S}/ftpd ${D}${sbindir}/ftpd-topfield
+ install -d ${D}${sysconfdir}/ ${D}${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/ftpd-topfield
+}