summaryrefslogtreecommitdiff
path: root/packages/freesmartphone
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-06-21 22:40:21 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-06-21 22:40:21 +0000
commita3bb9f21c1feabe7471a0057d966cce4fd9bae5f (patch)
tree170f97e75e45d14730dacde9cfe719d633dd9ca5 /packages/freesmartphone
parent5017d4e34081e5cd99e4458715ac6c86576fe1d1 (diff)
add freesmartphone frameworkd git
Diffstat (limited to 'packages/freesmartphone')
-rw-r--r--packages/freesmartphone/frameworkd/.mtn2git_empty0
-rw-r--r--packages/freesmartphone/frameworkd/frameworkd40
-rw-r--r--packages/freesmartphone/frameworkd/frameworkd.conf0
-rw-r--r--packages/freesmartphone/frameworkd/om-gta02/.mtn2git_empty0
-rw-r--r--packages/freesmartphone/frameworkd/om-gta02/frameworkd.conf8
-rw-r--r--packages/freesmartphone/frameworkd_git.bb37
6 files changed, 85 insertions, 0 deletions
diff --git a/packages/freesmartphone/frameworkd/.mtn2git_empty b/packages/freesmartphone/frameworkd/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/freesmartphone/frameworkd/.mtn2git_empty
diff --git a/packages/freesmartphone/frameworkd/frameworkd b/packages/freesmartphone/frameworkd/frameworkd
new file mode 100644
index 0000000000..08b782e402
--- /dev/null
+++ b/packages/freesmartphone/frameworkd/frameworkd
@@ -0,0 +1,40 @@
+#! /bin/sh
+#
+# frameworkd -- This shell script starts and stops the freemsmartphone.org framework daemon.
+#
+# chkconfig: 345 90 20
+# description: frameworkd is the freesmartphone.org framework daemon
+# processname: python
+
+PATH=/bin:/usr/bin:/sbin:/usr/sbin
+NAME=frameworkd
+
+[ -f /etc/default/rcS ] && . /etc/default/rcS
+
+case "$1" in
+ start)
+ echo -n "Starting freesmartphone.org framework daemon: "
+ start-stop-daemon --start --pidfile /var/run/${NAME}.pid --make-pidfile --background -x /usr/bin/frameworkd
+ if [ $? = 0 ]; then
+ echo "(ok)"
+ else
+ echo "(failed)"
+ fi
+ ;;
+ stop)
+ echo -n "Stopping freesmartphone.org framework daemon: "
+ start-stop-daemon --stop --pidfile /var/run/${NAME}.pid --oknodo
+ rm -f /var/run/${NAME}.pid
+ echo "(done)"
+ ;;
+ restart|force-reload)
+ $0 stop
+ $0 start
+ ;;
+ *)
+ echo "Usage: /etc/init.d/odeviced {start|stop|restart|force-reload}"
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/packages/freesmartphone/frameworkd/frameworkd.conf b/packages/freesmartphone/frameworkd/frameworkd.conf
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/freesmartphone/frameworkd/frameworkd.conf
diff --git a/packages/freesmartphone/frameworkd/om-gta02/.mtn2git_empty b/packages/freesmartphone/frameworkd/om-gta02/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/freesmartphone/frameworkd/om-gta02/.mtn2git_empty
diff --git a/packages/freesmartphone/frameworkd/om-gta02/frameworkd.conf b/packages/freesmartphone/frameworkd/om-gta02/frameworkd.conf
new file mode 100644
index 0000000000..0076639f98
--- /dev/null
+++ b/packages/freesmartphone/frameworkd/om-gta02/frameworkd.conf
@@ -0,0 +1,8 @@
+[idlenotifier]
+# don't read from accellerometers for now
+ignoreinput=2,3
+
+[input]
+# don't read from accellerometers for now
+ignoreinput=2,3
+
diff --git a/packages/freesmartphone/frameworkd_git.bb b/packages/freesmartphone/frameworkd_git.bb
new file mode 100644
index 0000000000..53ea10f0fb
--- /dev/null
+++ b/packages/freesmartphone/frameworkd_git.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "The freesmartphon.org Framework Daemon"
+HOMEPAGE = "http://www.freesmartphone.org"
+AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
+SECTION = "console/network"
+DEPENDS = "python-cython-native python-pyrex-native"
+LICENSE = "GPL"
+PV = "0.8.0+gitr${SRCREV}"
+PR = "r0"
+
+inherit distutils update-rc.d
+
+INITSCRIPT_NAME = "frameworkd"
+INITSCRIPT_PARAMS = "defaults 29"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/framework.git;protocol=git;branch=master \
+ file://frameworkd \
+ file://frameworkd.conf"
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/frameworkd ${D}${sysconfdir}/init.d/
+ install -m 0644 ${WORKDIR}/frameworkd.conf ${D}${sysconfdir}
+ install -d ${D}${sysconfdir}/dbus-1/system.d/
+ mv -f ${D}${datadir}/etc/dbus-1/system.d/frameworkd.conf ${D}${sysconfdir}/dbus-1/system.d/
+}
+
+RDEPENDS_${PN} += "\
+ python-dbus \
+ python-pygobject \
+ python-pyrtc \
+ python-pyserial \
+ python-syslog \
+"
+
+FILES_${PN} += "${sysconfdir}"
+FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/framework/subsystems/*/.debug"