summaryrefslogtreecommitdiff
path: root/packages/freesmartphone/zhone_git.bb
diff options
context:
space:
mode:
authorJan Lübbe <jluebbe@debian.org>2008-05-17 11:05:45 +0000
committerJan Lübbe <jluebbe@debian.org>2008-05-17 11:05:45 +0000
commitd7da261f228a694699f9ef66a1d5a200a335a141 (patch)
treedb1a2b6caf641a4ba3cab14b770d0cf92630f7d6 /packages/freesmartphone/zhone_git.bb
parentfa719019d592dd4724f1bea024131e7524d9d44e (diff)
freesmartphone: add a fso-image and fix bb-files
Diffstat (limited to 'packages/freesmartphone/zhone_git.bb')
-rw-r--r--packages/freesmartphone/zhone_git.bb20
1 files changed, 18 insertions, 2 deletions
diff --git a/packages/freesmartphone/zhone_git.bb b/packages/freesmartphone/zhone_git.bb
index 7fe6742069..419ee7a3e3 100644
--- a/packages/freesmartphone/zhone_git.bb
+++ b/packages/freesmartphone/zhone_git.bb
@@ -4,10 +4,26 @@ SECTION = "x11"
DEPENDS = "edje-native"
RDEPENDS = "task-python-efl python-textutils"
PV = "0.0.0+gitr${SRCREV}"
+PR = "r3"
-SRC_URI = "${FREESMARTPHONE_GIT}/zhone.git;protocol=git;branch=master"
+SRC_URI = "${FREESMARTPHONE_GIT}/zhone.git;protocol=git;branch=master \
+ file://80zhone"
S = "${WORKDIR}/git"
inherit autotools
-FILES_${PN} += "${datadir}"
+RDEPENDS_${PN} += "\
+ python-dbus \
+"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/X11/Xsession.d/
+ install -m 0755 ${WORKDIR}/80zhone ${D}${sysconfdir}/X11/Xsession.d/
+}
+
+FILES_${PN} += "${datadir} ${sysconfdir}"
+
+RCONFLICTS = "openmoko-session2"
+RREPLACES = "openmoko-session2"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+