summaryrefslogtreecommitdiff
path: root/packages/fakeroot/fakeroot_1.9.6.bb
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2009-02-25 20:34:02 -0600
committerMike Westerhof <mwester@dls.net>2009-02-25 20:34:02 -0600
commita64be907e3e038af29d7f4184971f10a7a0dec82 (patch)
treebc83c47ec6dfba9f9698c7cfb45da72e71f20a9b /packages/fakeroot/fakeroot_1.9.6.bb
parent50e689eec4e3dfe13d0e7a090d3173d315787af0 (diff)
SlugOS: reinstate fakeroot 1.9.6 and set as the PREFERRED_VERSION
Diffstat (limited to 'packages/fakeroot/fakeroot_1.9.6.bb')
-rw-r--r--packages/fakeroot/fakeroot_1.9.6.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/fakeroot/fakeroot_1.9.6.bb b/packages/fakeroot/fakeroot_1.9.6.bb
new file mode 100644
index 0000000000..aaf696d79d
--- /dev/null
+++ b/packages/fakeroot/fakeroot_1.9.6.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Gives a fake root environment"
+HOMEPAGE = "http://fakeroot.alioth.debian.org/"
+SECTION = "base"
+LICENSE = "GPL"
+# fakeroot needs getopt which is provided by the util-linux package
+RDEPENDS = "util-linux"
+PR = "r1"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \
+ file://configure-libtool.patch;patch=1"
+
+inherit autotools
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/fakeroot
+ install -m 644 *.h ${STAGING_INCDIR}/fakeroot
+ autotools_stage_all
+}