summaryrefslogtreecommitdiff
path: root/packages/fakeroot/fakeroot-native_1.9.1.bb
diff options
context:
space:
mode:
authorOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2008-01-28 08:06:48 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2008-01-28 08:06:48 +0000
commitb7546e3f46c52c23ab2cfbf0a0b1e13597cd20ef (patch)
tree1a90eec6d43d7bf4b7f12f2d3de3e8de24097152 /packages/fakeroot/fakeroot-native_1.9.1.bb
parent937675435a1f0e44511bdc8ff6ef1d5d4029d5b8 (diff)
parent2c7c8e8d65c63b9492ccc6f754fed2a4307908cd (diff)
merge of '36133f7d8e7f5d20b7036c64abff8ec2452f0282'
and 'cec9ba770f42c95b32a71550f948c06c6fdf7e48'
Diffstat (limited to 'packages/fakeroot/fakeroot-native_1.9.1.bb')
-rw-r--r--packages/fakeroot/fakeroot-native_1.9.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/fakeroot/fakeroot-native_1.9.1.bb b/packages/fakeroot/fakeroot-native_1.9.1.bb
new file mode 100644
index 0000000000..77d6f58651
--- /dev/null
+++ b/packages/fakeroot/fakeroot-native_1.9.1.bb
@@ -0,0 +1,21 @@
+require fakeroot_${PV}.bb
+
+RDEPENDS="util-linux-native"
+
+SRC_URI += "file://fix-prefix.patch;patch=1 "
+S = "${WORKDIR}/fakeroot-${PV}"
+
+inherit native
+
+EXTRA_OECONF = " --program-prefix="
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+ if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+ bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
+}
+
+do_stage_append () {
+ oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
+}
+