summaryrefslogtreecommitdiff
path: root/packages/espeak/espeak_1.35.bb
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2008-03-22 00:32:21 +0000
committerHolger Freyther <zecke@selfish.org>2008-03-22 00:32:21 +0000
commit0362af65b95845f571763fa56e6031a8089091fc (patch)
treebae11f352af2fc04b16ae6ddae46fc6cb51b36f5 /packages/espeak/espeak_1.35.bb
parent2f8d9c7a57e00b9acd7f7ac445b3ee6cd4eba886 (diff)
parenta4535d80cb60e8eb76cdd2570e76b39eee2332d0 (diff)
merge of '4216327dbc55e359d557266da86971e66ff5f595'
and 'd72643015c099d3f2c3ec5c5bb1294365effbe54'
Diffstat (limited to 'packages/espeak/espeak_1.35.bb')
-rw-r--r--packages/espeak/espeak_1.35.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/packages/espeak/espeak_1.35.bb b/packages/espeak/espeak_1.35.bb
new file mode 100644
index 0000000000..f7dacf54bc
--- /dev/null
+++ b/packages/espeak/espeak_1.35.bb
@@ -0,0 +1,45 @@
+require espeak.inc
+
+EXTRA_PHONEMES = '${@base_contains("SITEINFO_ENDIANESS", "be", "espeak-data (= ${PV})", "", d)}'
+RDEPENDS = "portaudio-v19 ${EXTRA_PHONEMES}"
+
+PR = "r1"
+
+CXXFLAGS += "-DUSE_PORTAUDIO"
+
+FILES_${PN} += "${datadir}/espeak-data"
+
+do_configure() {
+ # "speak" binary, a TTS engine, uses portaudio in either APIs V18 or V19, use V19
+ cp "${S}/src/portaudio19.h" "${S}/src/portaudio.h"
+}
+
+do_compile() {
+ cd src
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${libdir}
+ install -d ${D}${includedir}
+ install -d ${D}${datadir}/espeak-data
+
+ # we do not ship "speak" binary though.
+ install -m 0755 ${S}/src/espeak ${D}${bindir}
+ install -m 0644 ${S}/src/speak_lib.h ${D}${includedir}
+ oe_libinstall -so -C src libespeak ${D}${libdir}
+
+ if [ "${SITEINFO_ENDIANESS}" = "be" ] ; then
+ # the big-endian phon* files are provided by the package espeak-data
+ rm -f ${S}/espeak-data/phon*
+ fi
+
+ cp -prf ${S}/espeak-data/* ${D}${datadir}/espeak-data
+}
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/espeak
+ install -m 0644 ${S}/src/speak_lib.h ${STAGING_INCDIR}/espeak/
+ oe_libinstall -so -C src libespeak ${STAGING_LIBDIR}
+}