summaryrefslogtreecommitdiff
path: root/packages/efl/edje-native_0.5.0.018.bb
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2005-10-15 21:44:08 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-10-15 21:44:08 +0000
commitc68c62221ffd271d95e29985d829f94ed6e9f9ec (patch)
tree6b9a100bc6fe74c9dfc652e54dc7603e3af8a9a8 /packages/efl/edje-native_0.5.0.018.bb
parent8ba758b8cf10fa025d7d5deedab18e8e4afd579b (diff)
efl, e17: update to newest versions
- fixed e-modules build on amd64 - new options evas-xrender-x11 is not disabled for fb builds - stage new Evas_Engine_XRender_X11.h header - remove e-utils from e-image, currently broken
Diffstat (limited to 'packages/efl/edje-native_0.5.0.018.bb')
-rw-r--r--packages/efl/edje-native_0.5.0.018.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/efl/edje-native_0.5.0.018.bb b/packages/efl/edje-native_0.5.0.018.bb
new file mode 100644
index 0000000000..523c38ba46
--- /dev/null
+++ b/packages/efl/edje-native_0.5.0.018.bb
@@ -0,0 +1,28 @@
+include edje_${PV}.bb
+PR = "r2"
+
+REAL_TARGET_SYS := ${TARGET_SYS}
+
+inherit native
+DEPENDS = "evas-native ecore-native eet-native embryo-native imlib2-native"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/edje"
+
+EXTRA_OECONF = "--with-fb-only \
+ --with-evas-config=${STAGING_BINDIR}/evas-config-native \
+ --with-ecore-config=${STAGING_BINDIR}/ecore-config-native \
+ --with-eet-config=${STAGING_BINDIR}/eet-config-native \
+ --with-embryo-config=${STAGING_BINDIR}/embryo-config-native \
+ --with-imlib2-config=${STAGING_BINDIR}/imlib2-config-native "
+
+do_configure_prepend() {
+ sed -i 's:EMBRYO_PREFIX"/bin:"${STAGING_BINDIR}:' ${S}/src/bin/edje_cc_out.c
+# sed -i 's:/usr/bin/cpp:${STAGING_DIR}/cross/bin/${REAL_TARGET_SYS}-cpp:' ${S}/src/bin/edje_cc_parse.c
+# sed -i 's:/usr/bin/gcc:${STAGING_DIR}/cross/bin/${REAL_TARGET_SYS}-gcc:' ${S}/src/bin/edje_cc_parse.c
+}
+
+do_stage_append() {
+ edje_data_dir=`${STAGING_BINDIR}/edje-config-native --datadir`
+ # could also use ${STAGING_DATADIR}/edje/include
+ install -d $edje_data_dir/include
+ install -m 0644 data/include/edje.inc $edje_data_dir/include
+}