summaryrefslogtreecommitdiff
path: root/packages/efl/ecore
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-06-21 03:55:38 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-06-21 03:55:38 +0000
commitbdb62917622bbb63dc57c3535be15ca9dea4c13a (patch)
tree90732a754ab55f6dd69fbfe6b7a68cd2444df105 /packages/efl/ecore
parent923534e5bd8e956de3bb8a40b02c363bfe15ecdd (diff)
move older efl stuff to nonworking
Diffstat (limited to 'packages/efl/ecore')
-rw-r--r--packages/efl/ecore/.mtn2git_empty0
-rw-r--r--packages/efl/ecore/add-tslib-support.patch104
-rw-r--r--packages/efl/ecore/configure-abstract-sockets.patch16
-rw-r--r--packages/efl/ecore/configure.patch21
-rw-r--r--packages/efl/ecore/ecore_kernel_input_header.patch23
-rw-r--r--packages/efl/ecore/fix-tslib-configure.patch12
-rw-r--r--packages/efl/ecore/remove-bad-code.patch36
-rw-r--r--packages/efl/ecore/remove-tslib-configure.patch15
8 files changed, 0 insertions, 227 deletions
diff --git a/packages/efl/ecore/.mtn2git_empty b/packages/efl/ecore/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/efl/ecore/.mtn2git_empty
+++ /dev/null
diff --git a/packages/efl/ecore/add-tslib-support.patch b/packages/efl/ecore/add-tslib-support.patch
deleted file mode 100644
index c125122a91..0000000000
--- a/packages/efl/ecore/add-tslib-support.patch
+++ /dev/null
@@ -1,104 +0,0 @@
-
-#
-# tslib support for ecore, (C) Michael 'Mickey' Lauer <mickey@Vanille.de>
-#
-
---- ecore/src/lib/ecore_fb/ecore_fb.c~add-tslib-support.patch
-+++ ecore/src/lib/ecore_fb/ecore_fb.c
-@@ -4,6 +4,13 @@
- #include "Ecore_Fb.h"
- #include "ecore_private.h"
-
-+
-+#ifdef HAVE_TSLIB
-+#include <tslib.h>
-+#include <errno.h>
-+#endif
-+
-+
- #include <fcntl.h>
- #include <unistd.h>
- #include <stdio.h>
-@@ -77,6 +84,11 @@
- unsigned char z;
- };
-
-+#ifdef HAVE_TSLIB
-+struct tsdev *_ecore_fb_tslib_tsdev = NULL;
-+struct ts_sample _ecore_fb_tslib_event;
-+#endif
-+
- static void _ecore_fb_size_get(int *w, int *h);
- static int _ecore_fb_ts_fd_handler(void *data, Ecore_Fd_Handler *fd_handler);
- static int _ecore_fb_kbd_fd_handler(void *data, Ecore_Fd_Handler *fd_handler);
-@@ -269,10 +281,39 @@
- ecore_fb_init(const char *name __UNUSED__)
- {
- int prev_flags;
-+#ifdef HAVE_TSLIB
-+ char *tslib_tsdevice = NULL;
-+#endif
-
- _ecore_fb_init_count++;
- if (_ecore_fb_init_count > 1) return _ecore_fb_init_count;
-+#ifdef HAVE_TSLIB
-+ if ( ( tslib_tsdevice = getenv("TSLIB_TSDEVICE") ) != NULL )
-+ {
-+ printf( "ECORE_FB: TSLIB_TSDEVICE = '%s'\n", tslib_tsdevice );
-+ _ecore_fb_tslib_tsdev = ts_open( tslib_tsdevice, 1 ); /* 1 = nonblocking, 0 = blocking */
-+
-+ if ( !_ecore_fb_tslib_tsdev )
-+ {
-+ printf( "ECORE_FB: Can't ts_open (%s)\n", strerror( errno ) );
-+ return 0;
-+ }
-+
-+ if ( ts_config( _ecore_fb_tslib_tsdev ) )
-+ {
-+ printf( "ECORE_FB: Can't ts_config (%s)\n", strerror( errno ) );
-+ return 0;
-+ }
-+ _ecore_fb_ts_fd = ts_fd( _ecore_fb_tslib_tsdev );
-+ if ( _ecore_fb_ts_fd < 0 )
-+ {
-+ printf( "ECORE_FB: Can't open touchscreen (%s)\n", strerror( errno ) );
-+ return 0;
-+ }
-+ }
-+#else
- _ecore_fb_ts_fd = open("/dev/touchscreen/0", O_RDONLY);
-+#endif
- if (_ecore_fb_ts_fd >= 0)
- {
- prev_flags = fcntl(_ecore_fb_ts_fd, F_GETFL);
-@@ -790,7 +831,21 @@
- char *ptr;
- double t;
- int did_triple = 0;
--
-+
-+#ifdef HAVE_TSLIB
-+ if ( _ecore_fb_ts_apply_cal )
-+ num = ts_read_raw( _ecore_fb_tslib_tsdev, &_ecore_fb_tslib_event, 1 );
-+ else
-+ num = ts_read( _ecore_fb_tslib_tsdev, &_ecore_fb_tslib_event, 1 );
-+ if ( num != 1 )
-+ {
-+ return 1; /* no more samples at this time */
-+ }
-+ x = _ecore_fb_tslib_event.x;
-+ y = _ecore_fb_tslib_event.y;
-+ pressure = _ecore_fb_tslib_event.pressure;
-+ v = 1; /* loop, there might be more samples */
-+#else
- ptr = (char *)&(_ecore_fb_ts_event);
- ptr += _ecore_fb_ts_event_byte_count;
- num = sizeof(Ecore_Fb_Ts_Event) - _ecore_fb_ts_event_byte_count;
-@@ -811,6 +866,7 @@
- y = _ecore_fb_ts_event.y;
- }
- pressure = _ecore_fb_ts_event.pressure;
-+#endif
- /* add event to queue */
- /* always add a move event */
- if ((pressure) || (prev_pressure))
diff --git a/packages/efl/ecore/configure-abstract-sockets.patch b/packages/efl/ecore/configure-abstract-sockets.patch
deleted file mode 100644
index 359203b163..0000000000
--- a/packages/efl/ecore/configure-abstract-sockets.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Index: ecore-0.9.9.038/configure.in
-===================================================================
---- ecore-0.9.9.038.orig/configure.in
-+++ ecore-0.9.9.038/configure.in
-@@ -541,10 +541,7 @@ AC_ARG_ENABLE(abstract-sockets,
- [ want_abstract_sockets="yes"]
- )
- if test "x$want_abstract_sockets" = "xyes"; then
-- AC_ABSTRACT_SOCKET_TEST(
-- [AC_DEFINE(HAVE_ABSTRACT_SOCKETS, 1, [Have abstract sockets namespace])],
-- []
-- )
-+ HAVE_ABSTRACT_SOCKETS = 1
- fi
-
- ECORE_CHECK_MODULE([Con], [yes])
diff --git a/packages/efl/ecore/configure.patch b/packages/efl/ecore/configure.patch
deleted file mode 100644
index 23d8193b44..0000000000
--- a/packages/efl/ecore/configure.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- ecore-0.9.9.036/configure.in.bak 2006-11-13 14:01:10.000000000 -0800
-+++ ecore-0.9.9.036/configure.in 2006-11-13 14:02:15.000000000 -0800
-@@ -16,7 +16,6 @@
- AC_CHECK_SIZEOF(long, 4)
- AM_ENABLE_SHARED
- AM_PROG_LIBTOOL
--AC_C___ATTRIBUTE__
-
- if test "x${bindir}" = 'xNONE'; then
- if test "x${prefix}" = "xNONE"; then
-@@ -200,9 +199,7 @@
- AM_CONDITIONAL(BUILD_ECORE_X, true)
- AC_DEFINE(BUILD_ECORE_X, 1, [Build Ecore_X Module])
- have_ecore_x="yes"
-- x_dir=${x_dir:-/usr/X11R6}
-- x_cflags=${x_cflags:--I${x_includes:-$x_dir/include}}
-- x_libs="${x_libs:--L${x_libraries:-$x_dir/lib}} -lX11 -lXext"
-+ x_libs="-lX11 -lXext"
- ecore_x_libs="-lecore_x $x_libs";
- ],[
- AM_CONDITIONAL(BUILD_ECORE_X, false)
diff --git a/packages/efl/ecore/ecore_kernel_input_header.patch b/packages/efl/ecore/ecore_kernel_input_header.patch
deleted file mode 100644
index 99f57ddcff..0000000000
--- a/packages/efl/ecore/ecore_kernel_input_header.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Index: ecore-0.9.9.036/src/lib/ecore_fb/ecore_fb_li.c
-===================================================================
---- ecore-0.9.9.036.orig/src/lib/ecore_fb/ecore_fb_li.c 2006-09-05 01:36:43.000000000 +0100
-+++ ecore-0.9.9.036/src/lib/ecore_fb/ecore_fb_li.c 2006-12-02 21:55:54.000000000 +0000
-@@ -1,6 +1,18 @@
- #include "Ecore_Fb.h"
- #include "ecore_fb_private.h"
-
-+struct input_absinfo {
-+ __s32 value;
-+ __s32 minimum;
-+ __s32 maximum;
-+ __s32 fuzz;
-+ __s32 flat;
-+};
-+
-+
-+#define EV_SYN 0x00
-+#define EV_PWR 0x16
-+#define EV_FF_STATUS 0x17
-
- /* Copyright (C) Brad Hards (1999-2002).
- * this macro is used to tell if "bit" is set in "array"
diff --git a/packages/efl/ecore/fix-tslib-configure.patch b/packages/efl/ecore/fix-tslib-configure.patch
deleted file mode 100644
index 2c82b2741e..0000000000
--- a/packages/efl/ecore/fix-tslib-configure.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nur ecore-0.9.9.037~/configure.in ecore-0.9.9.037/configure.in
---- ecore-0.9.9.037~/configure.in 2007-01-14 20:21:42.000000000 -0800
-+++ ecore-0.9.9.037/configure.in 2007-01-14 20:22:18.000000000 -0800
-@@ -578,7 +578,7 @@
- if test "x$want_ecore_fb" = "xyes"; then
- AC_CHECK_HEADER(tslib.h,
- [
-- tslib_libs="-ltslib"
-+ tslib_libs="-lts"
- AC_DEFINE(HAVE_TSLIB, 1, [Build Ecore_FB Touchscreen Code])
- ]
- )
diff --git a/packages/efl/ecore/remove-bad-code.patch b/packages/efl/ecore/remove-bad-code.patch
deleted file mode 100644
index 87a8d16bd6..0000000000
--- a/packages/efl/ecore/remove-bad-code.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Index: ecore-0.9.9.037/src/lib/ecore_fb/ecore_fb_private.h
-===================================================================
---- ecore-0.9.9.037.orig/src/lib/ecore_fb/ecore_fb_private.h
-+++ ecore-0.9.9.037/src/lib/ecore_fb/ecore_fb_private.h
-@@ -19,8 +19,8 @@
- #define kernel_ulong_t unsigned long
- #define BITS_PER_LONG 32
- #include <linux/input.h>
-- #undef kernel_ulong_t <-added
-- #undef BITS_PER_LONG <-added
-+ #undef kernel_ulong_t
-+ #undef BITS_PER_LONG
- #else
- #include <linux/input.h>
- #endif
-Index: ecore-0.9.9.037/src/lib/ecore_fb/ecore_fb_li.c
-===================================================================
---- ecore-0.9.9.037.orig/src/lib/ecore_fb/ecore_fb_li.c
-+++ ecore-0.9.9.037/src/lib/ecore_fb/ecore_fb_li.c
-@@ -1,6 +1,6 @@
- #include "Ecore_Fb.h"
- #include "ecore_fb_private.h"
--
-+/*
- struct input_absinfo {
- __s32 value;
- __s32 minimum;
-@@ -8,7 +8,7 @@ struct input_absinfo {
- __s32 fuzz;
- __s32 flat;
- };
--
-+*/
-
- #define EV_SYN 0x00
- #define EV_PWR 0x16
diff --git a/packages/efl/ecore/remove-tslib-configure.patch b/packages/efl/ecore/remove-tslib-configure.patch
deleted file mode 100644
index 40ed1c2c33..0000000000
--- a/packages/efl/ecore/remove-tslib-configure.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- ecore/configure.in.~1.125.~ 2005-11-29 01:13:26.000000000 -0800
-+++ ecore/configure.in 2006-01-12 11:21:42.000000000 -0800
-@@ -101,12 +101,6 @@
- AC_CHECK_FUNCS(gettimeofday)
-
- tslib_libs=""
--AC_CHECK_HEADER(tslib.h,
-- [
-- tslib_libs="-ltslib"
-- AC_DEFINE(HAVE_TSLIB, 1, [Build Ecore_X Module])
-- ]
--)
- AC_SUBST(tslib_libs)
-
- AC_CHECK_HEADERS(netinet/in.h)