summaryrefslogtreecommitdiff
path: root/packages/ecj/ecj-bootstrap-native_3.3.bb
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2008-01-09 13:22:37 +0000
committerRobert Schuster <thebohemian@gmx.net>2008-01-09 13:22:37 +0000
commitabf51ba185546d0f5af8316cfd7ee8d2b9992c38 (patch)
tree93e45f91f73eeab2a2e83f6d3d6a77900a0913c0 /packages/ecj/ecj-bootstrap-native_3.3.bb
parent8f073edcc8e3324117e1f869b65d577e0cf2e4f1 (diff)
jamvm: Added -initial version.
cacao: Multiple fixes. - added -initial version - added -native snapshot version classpath: - added -initial version - added -native version ecj: - added -initial version - added -native version that is compiled from source jikes: - jikes-native is not a virtual/javac-native provider any more
Diffstat (limited to 'packages/ecj/ecj-bootstrap-native_3.3.bb')
-rw-r--r--packages/ecj/ecj-bootstrap-native_3.3.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/ecj/ecj-bootstrap-native_3.3.bb b/packages/ecj/ecj-bootstrap-native_3.3.bb
new file mode 100644
index 0000000000..bd4347457c
--- /dev/null
+++ b/packages/ecj/ecj-bootstrap-native_3.3.bb
@@ -0,0 +1,38 @@
+# ECJ as a bootstrap compiler is a drop-in replacement for Sun's javac. It offers no more
+# and no less features.
+#
+# Since the VM running the compiler has no effect on the produced bytecode this recipe
+# uses the jar created by ecj-initial and creates a start script that runs it with a different
+# VM.
+
+DESCRIPTION = "JDT Core Batch Compiler - Bootstrap variant"
+HOMEPAGE = "http://www.eclipse.org/"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "EPL"
+
+DEPENDS = "ecj-initial virtual/java-native"
+
+PROVIDES = "virtual/javac-native"
+
+SRC_URI = "file://ecj.in"
+
+S = "${WORKDIR}"
+
+JAR = "ecj-bootstrap-${PV}.jar"
+
+inherit native
+
+do_compile() {
+ # Create the start script
+ echo "#!/bin/sh" > ecj-bootstrap
+ echo "ECJ_JAR=${STAGING_DATADIR}/java/${JAR}" >> ecj-bootstrap
+ echo "RUNTIME=java" >> ecj-bootstrap
+ cat ecj.in >> ecj-bootstrap
+}
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ install -m 755 ${S}/ecj-bootstrap ${STAGING_BINDIR}
+ install -m 755 ${S}/ecj-bootstrap ${STAGING_BINDIR}/javac
+}