summaryrefslogtreecommitdiff
path: root/packages/e17/entrance_0.9.0.010.bb
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-06-21 16:08:16 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-06-21 16:08:16 +0000
commitba68b5b60c6b212df3ac763a9283462564403330 (patch)
tree976a4391a5e19d6835f314598ed1cb24fa3a4c09 /packages/e17/entrance_0.9.0.010.bb
parentfa1cb20696128f0b580187f779aac90b879456f7 (diff)
parent07903f2bd73ad78932437c6dcfb45c25f722fc57 (diff)
merge of 'aaafb999d11846eacd606047f3cddf7a583a9e0c'
and 'b0652ec03153efab79c1e4fedf9f6847d4695672'
Diffstat (limited to 'packages/e17/entrance_0.9.0.010.bb')
-rw-r--r--packages/e17/entrance_0.9.0.010.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/packages/e17/entrance_0.9.0.010.bb b/packages/e17/entrance_0.9.0.010.bb
new file mode 100644
index 0000000000..4c47f1d2ab
--- /dev/null
+++ b/packages/e17/entrance_0.9.0.010.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Entrance is the Enlightenment login manager"
+LICENSE = "MIT"
+# can also use pam and crypt
+DEPENDS = "evas ecore edje esmart bash keylaunch xserver-common login-manager"
+RDEPENDS += "glibc-gconv-iso8859-1 entrance-themes"
+PR = "r0"
+
+inherit e
+
+SRC_URI += "\
+ file://config-db.patch;patch=1 \
+ file://allow-missing-xsession.patch;patch=1 \
+ file://run-Xinit.patch;patch=1 \
+ file://fix-auth-mode.patch;patch=1 \
+ file://use-bash.patch;patch=1 \
+ file://Sessions"
+
+S = "${WORKDIR}/entrance-${PV}"
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
+ --with-xsession=/etc/X11/Xsession \
+ --with-auth-mode=0"
+
+FILES_${PN}-dbg += "${libexecdir}/entrance/.debug/*"
+
+do_install_append() {
+ install -d ${D}/etc/X11/Xsession.d
+ install -d ${D}/etc/X11/Sessions
+
+ install -m 755 ${WORKDIR}/Sessions/* ${D}/etc/X11/Sessions
+
+ install -d ${D}/etc/X11/login-managers/
+ mv ${D}/etc/init.d/entrance ${D}/etc/X11/login-managers/entrance
+}