summaryrefslogtreecommitdiff
path: root/packages/e17/entrance
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-06-21 03:51:17 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-06-21 03:51:17 +0000
commita375ded2d26d83858eb03dcb716f76969f8efa4c (patch)
tree31df8b093e56d48282878cef75d8fd02f051407e /packages/e17/entrance
parent2a018a41a0106416788e36c574375c7654f27e33 (diff)
e17 applications: catch up with EFL overhaul
Diffstat (limited to 'packages/e17/entrance')
-rw-r--r--packages/e17/entrance/allow-missing-xsession.patch22
-rw-r--r--packages/e17/entrance/config-db.patch136
-rw-r--r--packages/e17/entrance/fix-auth-mode.patch10
-rw-r--r--packages/e17/entrance/use-bash.patch63
4 files changed, 156 insertions, 75 deletions
diff --git a/packages/e17/entrance/allow-missing-xsession.patch b/packages/e17/entrance/allow-missing-xsession.patch
index c475e46fe2..74289ad3c8 100644
--- a/packages/e17/entrance/allow-missing-xsession.patch
+++ b/packages/e17/entrance/allow-missing-xsession.patch
@@ -1,18 +1,18 @@
---- entrance/configure.in.~1.42.~ 2005-07-29 23:15:58.000000000 -0700
-+++ entrance/configure.in 2005-08-13 03:11:41.000000000 -0700
-@@ -190,11 +190,11 @@
+Index: entrance-0.9.0.009/configure.in
+===================================================================
+--- entrance-0.9.0.009.orig/configure.in
++++ entrance-0.9.0.009/configure.in
+@@ -184,10 +184,10 @@ AC_ARG_WITH(xsession,
fi
]
)
--if test ! -x $xsession ; then
-- AC_MSG_WARN([** no $xsession file on this system **])
-- AC_MSG_WARN([** Perhaps you need to specify --with-xsession **])
-- xsession="You should reconfigure --with-xsession"
+-if test ! -x "$xsession" ; then
+- AC_MSG_WARN([** $xsession does not exist or is not executable **])
+- AC_MSG_WARN([** Please consider overriding with --with-xsession **])
-fi
-+#if test ! -x $xsession ; then
-+# AC_MSG_WARN([** no $xsession file on this system **])
-+# AC_MSG_WARN([** Perhaps you need to specify --with-xsession **])
-+# xsession="You should reconfigure --with-xsession"
++#if test ! -x "$xsession" ; then
++# AC_MSG_WARN([** $xsession does not exist or is not executable **])
++# AC_MSG_WARN([** Please consider overriding with --with-xsession **])
+#fi
AC_DEFINE_UNQUOTED(ENTRANCE_XSESSION, "$xsession", [Xsession script])
diff --git a/packages/e17/entrance/config-db.patch b/packages/e17/entrance/config-db.patch
index 83ed3acf84..aecbfb6867 100644
--- a/packages/e17/entrance/config-db.patch
+++ b/packages/e17/entrance/config-db.patch
@@ -1,43 +1,119 @@
---- entrance/data/config/build_config.sh.in.~1.18.~ 2006-01-11 18:46:48.000000000 -0800
-+++ entrance/data/config/build_config.sh.in 2006-01-11 21:52:54.000000000 -0800
-@@ -18,29 +18,14 @@
+Index: entrance-0.9.0.009/data/config/build_config.sh.in
+===================================================================
+--- entrance-0.9.0.009.orig/data/config/build_config.sh.in
++++ entrance-0.9.0.009/data/config/build_config.sh.in
+@@ -1,45 +1,45 @@
+ #!/bin/sh -e
+
+-usage() {
+- cat <<-EOF
+- Usage: $0 [options]
+-
+- Options:
+- -d, --dir Session directory to scan
+- -c, --file Config file (default: $DB)
+- -h, --help This help output :p
+- EOF
+-
+- if [ "$1" = "1" ] ; then
+- echo ""
+- echo "ERROR: $2"
+- fi
+-
+- exit $1
+-}
+-
+-SESSION_DIR=""
+-DB="./entrance_config.cfg"
+-
+-while [ -n "$1" ] ; do
+- case $1 in
+- -d) shift; SESSION_DIR=$1;;
+- -c) shift; DB=$1;;
+- -h) usage 0;;
+- *) usage 1 "Unknown option: $1";;
+- esac
+- shift
+-done
+-
+-if [ -z "$DB" ] || [ -d "$DB" ] ; then
+- usage 1 "Invalid DB argument"
+-fi
+-
+-FROM=$SESSION_DIR
+-if [ -z "$FROM" ] ; then
+- FROM="defaults"
+-fi
+-echo "Generating config file '$DB' from '$FROM' ..."
++#usage() {
++# cat <<-EOF
++# Usage: $0 [options]
++#
++# Options:
++# -d, --dir Session directory to scan
++# -c, --file Config file (default: $DB)
++# -h, --help This help output :p
++# EOF
++#
++# if [ "$1" = "1" ] ; then
++# echo ""
++# echo "ERROR: $2"
++# fi
++#
++# exit $1
++#}
++#
++#SESSION_DIR=""
++#DB="./entrance_config.cfg"
++#
++#while [ -n "$1" ] ; do
++# case $1 in
++# -d) shift; SESSION_DIR=$1;;
++# -c) shift; DB=$1;;
++# -h) usage 0;;
++# *) usage 1 "Unknown option: $1";;
++# esac
++# shift
++#done
++#
++#if [ -z "$DB" ] || [ -d "$DB" ] ; then
++# usage 1 "Invalid DB argument"
++#fi
++#
++#FROM=$SESSION_DIR
++#if [ -z "$FROM" ] ; then
++# FROM="defaults"
++#fi
++#echo "Generating config file '$DB' from '$FROM' ..."
+
+ rm -f $DB || exit 1
+
+@@ -59,10 +59,10 @@ ecore_config -c $DB -k /entrance/time_fo
#ecore_config -c $DB -k /entrance/fonts/0/-s -s "/usr/share/fonts/truetype/"
#ecore_config -c $DB -k /entrance/fonts/1/-s -s "/usr/X11R6/lib/X11/fonts/Truetype/"
ecore_config -c $DB -k /entrance/greeting/before -s "Welcome to"
-ecore_config -c $DB -k /entrance/greeting/after -s ""
--ecore_config -c $DB -k /entrance/session/count -i 7
--ecore_config -c $DB -k /entrance/session/0/session -s "default"
+ecore_config -c $DB -k /entrance/greeting/after -s " e17/OE"
-+ecore_config -c $DB -k /entrance/session/count -i 2
+
+ count=0
+-ecore_config -c $DB -k /entrance/session/0/session -s "default"
+ecore_config -c $DB -k /entrance/session/0/session -s "/etc/X11/Sessions/Enlightenment"
ecore_config -c $DB -k /entrance/session/0/title -s "Default"
ecore_config -c $DB -k /entrance/session/0/icon -s "default.png"
- ecore_config -c $DB -k /entrance/session/1/icon -s "enlightenment.png"
- ecore_config -c $DB -k /entrance/session/1/title -s "E17"
--ecore_config -c $DB -k /entrance/session/1/session -s "@prefix@/bin/enlightenment"
--ecore_config -c $DB -k /entrance/session/2/session -s "kde"
--ecore_config -c $DB -k /entrance/session/2/title -s "KDE"
--ecore_config -c $DB -k /entrance/session/2/icon -s "kde.png"
--ecore_config -c $DB -k /entrance/session/3/session -s "gnome"
--ecore_config -c $DB -k /entrance/session/3/title -s "Gnome"
--ecore_config -c $DB -k /entrance/session/3/icon -s "gnome.png"
--ecore_config -c $DB -k /entrance/session/4/session -s "Enlightenment"
--ecore_config -c $DB -k /entrance/session/4/title -s "E16"
--ecore_config -c $DB -k /entrance/session/4/icon -s "enlightenment.png"
--ecore_config -c $DB -k /entrance/session/5/session -s "xfce"
--ecore_config -c $DB -k /entrance/session/5/title -s "XFce"
--ecore_config -c $DB -k /entrance/session/5/icon -s "xfce.png"
--ecore_config -c $DB -k /entrance/session/6/session -s "failsafe"
--ecore_config -c $DB -k /entrance/session/6/title -s "Failsafe"
--ecore_config -c $DB -k /entrance/session/6/icon -s "failsafe.png"
-+ecore_config -c $DB -k /entrance/session/1/session -s "/etc/X11/Sessions/Enlightenment"
- ecore_config -c $DB -k /entrance/system/reboot -i 1
- ecore_config -c $DB -k /entrance/system/halt -i 1
- ecore_config -c $DB -k /entrance/user/remember -i 1
-@@ -50,5 +35,5 @@
+ #if [ -z "$SESSION_DIR" ] ; then
+@@ -92,7 +92,7 @@ ecore_config -c $DB -k /entrance/session
+ # done
+ #fi
+ count=`(expr $count + 1)`
+-ecore_config -c $DB -k /entrance/session/$count/session -s "failsafe"
++ecore_config -c $DB -k /entrance/session/$count/session -s "/etc/X11/Sessions/Enlightenment"
+ ecore_config -c $DB -k /entrance/session/$count/title -s "Failsafe"
+ ecore_config -c $DB -k /entrance/session/$count/icon -s "failsafe.png"
+ count=`(expr $count + 1)`
+@@ -107,5 +107,5 @@ ecore_config -c $DB -k /entrance/autolog
ecore_config -c $DB -k /entrance/presel/mode -i 1
# for Entranced
--ecore_config -c $DB -k /entranced/xserver -s "/usr/X11R6/bin/X -quiet -nolisten tcp"
+-ecore_config -c $DB -k /entranced/xserver -s "@xbin@/X -quiet -nolisten tcp@ENTRANCE_VT_ARG@"
+ecore_config -c $DB -k /entranced/xserver -s "/etc/X11/Xserver"
ecore_config -c $DB -k /entranced/attempts -i 5
diff --git a/packages/e17/entrance/fix-auth-mode.patch b/packages/e17/entrance/fix-auth-mode.patch
index 1ec520f768..46e530b256 100644
--- a/packages/e17/entrance/fix-auth-mode.patch
+++ b/packages/e17/entrance/fix-auth-mode.patch
@@ -1,7 +1,9 @@
---- entrance/data/config/build_config.sh.in~ 2006-01-30 07:01:47.000000000 -0800
-+++ entrance/data/config/build_config.sh.in 2006-02-01 22:22:04.000000000 -0800
-@@ -3,7 +3,7 @@
- rm -f $DB
+Index: entrance-0.9.0.009/data/config/build_config.sh.in
+===================================================================
+--- entrance-0.9.0.009.orig/data/config/build_config.sh.in
++++ entrance-0.9.0.009/data/config/build_config.sh.in
+@@ -44,7 +44,7 @@
+ rm -f $DB || exit 1
# set auth to 1 for pam, 2 for shadow
-ecore_config -c $DB -k /entrance/auth -i @auth_mode@
diff --git a/packages/e17/entrance/use-bash.patch b/packages/e17/entrance/use-bash.patch
index 58ef8f556f..7dfab83711 100644
--- a/packages/e17/entrance/use-bash.patch
+++ b/packages/e17/entrance/use-bash.patch
@@ -1,19 +1,33 @@
-diff -Nur entrance~/src/client/entrance_session.c entrance/src/client/entrance_session.c
---- entrance~/src/client/entrance_session.c 2006-02-02 19:51:40.000000000 -0800
-+++ entrance/src/client/entrance_session.c 2006-02-02 19:59:24.000000000 -0800
-@@ -495,7 +495,7 @@
- entrance_session_free(e);
- /* replace this process with a clean small one that just waits for its */
- /* child to exit.. passed on the cmd-line */
-- execl("/bin/sh", "/bin/sh", "-l", "-c", buf, NULL);
-+ execl("/bin/bash", "/bin/bash", "-l", "-c", buf, NULL);
- }
+Index: entrance-0.9.0.009/src/client/entrance_session.c
+===================================================================
+--- entrance-0.9.0.009.orig/src/client/entrance_session.c
++++ entrance-0.9.0.009/src/client/entrance_session.c
+@@ -854,7 +854,7 @@ _entrance_session_execute_in_shell(char
+ if (shell && (strlen(shell) > 0))
+ shell_cmd = shell;
+ else
+- shell_cmd = strdup("/bin/sh");
++ shell_cmd = strdup("/bin/bash");
+ if (session_name)
+ snprintf(buf, sizeof(buf), "%s %s", session_cmd, session_name);
+@@ -869,9 +869,9 @@ _entrance_session_execute_in_shell(char
+ if (res == -1)
+ /* TODO: should actually hit the user in the face with this message */
+ syslog(LOG_NOTICE,
+- "Neither '%s' or '/bin/sh' are working login shells for user '%s'. Your session may not function properly. ",
++ "Neither '%s' or '/bin/bash' are working login shells for user '%s'. Your session may not function properly. ",
+ shell, user);
+- shell_cmd = strdup("/bin/sh");
++ shell_cmd = strdup("/bin/bash");
+
+ res = execlp(shell_cmd, shell_cmd, "-c", buf, NULL);
-diff -Nur entrance~/src/client/main.c entrance/src/client/main.c
---- entrance~/src/client/main.c 2006-02-02 19:51:40.000000000 -0800
-+++ entrance/src/client/main.c 2006-02-02 19:57:24.000000000 -0800
-@@ -392,7 +392,7 @@
+Index: entrance-0.9.0.009/src/client/main.c
+===================================================================
+--- entrance-0.9.0.009.orig/src/client/main.c
++++ entrance-0.9.0.009/src/client/main.c
+@@ -453,7 +453,7 @@ reboot_cb(void *data, Evas_Object * o, c
{
case 0:
if (execl
@@ -22,7 +36,7 @@ diff -Nur entrance~/src/client/main.c entrance/src/client/main.c
{
syslog(LOG_CRIT,
"Reboot failed: Unable to execute /sbin/shutdown");
-@@ -434,7 +434,7 @@
+@@ -495,7 +495,7 @@ shutdown_cb(void *data, Evas_Object * o,
{
case 0:
if (execl
@@ -31,24 +45,13 @@ diff -Nur entrance~/src/client/main.c entrance/src/client/main.c
{
syslog(LOG_CRIT,
"Shutdown failed: Unable to execute /sbin/shutdown");
-diff -Nur entrance~/src/daemon/entrance_wrapper.in entrance/src/daemon/entrance_wrapper.in
---- entrance~/src/daemon/entrance_wrapper.in 2006-02-02 19:51:40.000000000 -0800
-+++ entrance/src/daemon/entrance_wrapper.in 2006-02-02 19:56:43.000000000 -0800
+Index: entrance-0.9.0.009/src/daemon/entrance_wrapper.in
+===================================================================
+--- entrance-0.9.0.009.orig/src/daemon/entrance_wrapper.in
++++ entrance-0.9.0.009/src/daemon/entrance_wrapper.in
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Wrapper script to set up login environment:
# Load up all the junk in /etc/profile first, and then
# pass control to entrance proper.
-diff -Nur entrance~/src/daemon/spawner.c entrance/src/daemon/spawner.c
---- entrance~/src/daemon/spawner.c 2006-02-02 19:51:40.000000000 -0800
-+++ entrance/src/daemon/spawner.c 2006-02-02 19:57:10.000000000 -0800
-@@ -162,7 +162,7 @@
- sigaction(SIGUSR1, &_entrance_x_sa, NULL);
- /* FIXME: need to parse command and NOT go thru /bin/sh!!!! */
- /* why? some /bin/sh's wont pass on this SIGUSR1 thing... */
-- execl("/bin/sh", "/bin/sh", "-c", x_cmd, NULL);
-+ execl("/bin/bash", "/bin/bash", "-c", x_cmd, NULL);
- syslog(LOG_WARNING, "Could not execute X server.");
- exit(1);
- default: