summaryrefslogtreecommitdiff
path: root/packages/dsplink
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2008-05-24 13:14:02 +0000
committerPhilip Balister <philip@balister.org>2008-05-24 13:14:02 +0000
commite43c9a81a4400540763d88caa5c377f06f78916e (patch)
treef7cf1b58ad94ec05e2cda0118335693fd62cf31c /packages/dsplink
parentd98395887f7dc3a675cd316e25d8e59d65905d91 (diff)
dsplink : More build fixes. bb file builds without errors at this point.
More work needed.
Diffstat (limited to 'packages/dsplink')
-rw-r--r--packages/dsplink/dsplink_1.50.bb4
-rw-r--r--packages/dsplink/files/davinci_mvlpro5.0.mk6
2 files changed, 7 insertions, 3 deletions
diff --git a/packages/dsplink/dsplink_1.50.bb b/packages/dsplink/dsplink_1.50.bb
index 56c2905f62..307d1836e1 100644
--- a/packages/dsplink/dsplink_1.50.bb
+++ b/packages/dsplink/dsplink_1.50.bb
@@ -47,7 +47,11 @@ PARALLEL_MAKE = ""
do_compile () {
ln -sf ${S}/gpp/src/api/*h ${S}/gpp/inc/
ln -sf ${S}/gpp/src/pmgr/Linux/2.6.18 ${S}/gpp/src/pmgr/Linux/2.6.26-rc2-omap1
+ ln -sf ${S}/gpp/src/pmgr/Linux/drv_pmgr.h ${S}/gpp/inc/drv_pmgr.h
+ ln -sf ${S}/gpp/src/pmgr/pmgr_proc.h ${S}/gpp/inc/pmgr_proc.h
+
unset DISPLAY
+
oe_runmake -C ${S}/gpp/src
}
diff --git a/packages/dsplink/files/davinci_mvlpro5.0.mk b/packages/dsplink/files/davinci_mvlpro5.0.mk
index 2ea2fd8915..66365f607b 100644
--- a/packages/dsplink/files/davinci_mvlpro5.0.mk
+++ b/packages/dsplink/files/davinci_mvlpro5.0.mk
@@ -78,7 +78,7 @@ endif
# Name of the compiler
# ----------------------------------------------------------------------------
COMPILER := SED_ME_TARGET_PREFIXgcc
-LD := SED_ME_TARGET_PREFIXDIR-ld
+LD := SED_ME_TARGET_PREFIXld
CROSS_COMPILE := SED_ME_TARGET_PREFIX
export CROSS_COMPILE
@@ -135,7 +135,7 @@ STD_CC_DEFNS := -D_REENTRANT
# ============================================================================
# ARCHIVER1 - This denotes the linker.
# ============================================================================
-ARCHIVER1 := SED_ME_TARGET_PREFIX-ld
+ARCHIVER1 := SED_ME_TARGET_PREFIXld
# ----------------------------------------------------------------------------
# Standard flags for the archiver
@@ -146,7 +146,7 @@ STD_AR_FLAGS1 := -EL -r
# ============================================================================
# ARCHIVER2 - This denotes the archiver.
# ============================================================================
-ARCHIVER2 := SED_ME_TARGET_PREFIX-ar
+ARCHIVER2 := SED_ME_TARGET_PREFIXar
# ----------------------------------------------------------------------------
# Standard flags for the archiver