summaryrefslogtreecommitdiff
path: root/packages/dsplink/dsplink.inc
diff options
context:
space:
mode:
authorRoger Monk <r-monk@ti.com>2009-02-18 14:05:11 +0100
committerKoen Kooi <koen@openembedded.org>2009-02-18 15:13:51 +0100
commit9485db7d15f237dea8cc841e6a1b5bc4930f15da (patch)
tree0dfce75146fe7e24d93eb0fc688cfe91fa464f89 /packages/dsplink/dsplink.inc
parent09b88241b5e95c441544a02c50db885cbf6d8ee8 (diff)
codec-engine: fix lpm build and clean up old files
Diffstat (limited to 'packages/dsplink/dsplink.inc')
-rw-r--r--packages/dsplink/dsplink.inc34
1 files changed, 20 insertions, 14 deletions
diff --git a/packages/dsplink/dsplink.inc b/packages/dsplink/dsplink.inc
index 002d08d2a7..f617a7e3d8 100644
--- a/packages/dsplink/dsplink.inc
+++ b/packages/dsplink/dsplink.inc
@@ -58,36 +58,42 @@ do_compile () {
unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
export KDIR=${STAGING_KERNEL_DIR}
- make -e all
+
+ make -e driver
+ make -e library
+ make -e samples
+
make -e -f ${WORKDIR}/Makefile-dsplink-dsp
+ cp -a * ${DSPLINK}/gpp/export/BIN/Linux/${DSPLINKPLATFORM}/RELEASE
#lpm bits
if [ -e ${S}/cetools/packages/ti/bios/power/ ] ; then
- echo "MVTOOL_PREFIX=${TARGET_PREFIX}" > ${S}/Rules.make
- echo "UCTOOL_PREFIX=${TARGET_PREFIX}" >> ${S}/Rules.make
- echo "LINUXKERNEL_INSTALL_DIR=${STAGING_KERNEL_DIR}" >> ${S}/Rules.make
- #export DSPLINK=${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/dsplink
-
+
# Build the DSP power manager kernel module
cd ${S}/cetools/packages/ti/bios/power/modules/${DSPPOWERSOC}/lpm
+ # Still need to move this into the patch file
if [ $(echo ${KERNEL_VERSION} | cut -c5,6) -gt 26 ] ; then
sed -i -e s:asm/semaphore:linux/semaphore: lpm_driver.c
fi
+ #what is this for?
rm -f *o
- make KERNEL_PATH=${STAGING_KERNEL_DIR} \
- KERNEL_SRC=${STAGING_KERNEL_DIR} \
- KERNEL_DIR=${STAGING_KERNEL_DIR} \
- KERNEL_VERSION=${KERNEL_VERSION} \
- TOOL_PREFIX=${TARGET_PREFIX} \
- DSPLINK_REPO=${DSPLINK}/../ \
- CC="${KERNEL_CC}" LD="${KERNEL_LD}" \
- AR="${KERNEL_AR}"
+
+ # lpm also needs KERNEL_INSTALL_DIR and MVTOOL_PREFIX which come from ti-paths.inc
+ export DSPLINK_REPO=${DSPLINK}/..
+ # should move the clean step into the clean stage..
+ #oe_runmake clean
+ oe_runmake
fi
#cmemk bits
if [ -e ${S}/cetools/packages/ti/sdo/linuxutils/cmem ] ; then
+ echo "MVTOOL_PREFIX=${TARGET_PREFIX}" > ${S}/Rules.make
+ echo "UCTOOL_PREFIX=${TARGET_PREFIX}" >> ${S}/Rules.make
+ echo "LINUXKERNEL_INSTALL_DIR=${STAGING_KERNEL_DIR}" >> ${S}/Rules.make
+ #export DSPLINK=${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/dsplink
+
# Build the cmem kernel module
# We unset CFLAGS because kernel modules need different ones, this is basically a verbatim copy of kernel.bbclass and module-base.bbclass
unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS