summaryrefslogtreecommitdiff
path: root/packages/dsplink/dsplink.inc
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-07-16 08:33:56 +0000
committerKoen Kooi <koen@openembedded.org>2008-07-16 08:33:56 +0000
commit4ff8f98603885e1647668f4c218969b65d778f54 (patch)
treef987fb98b992cd3a8920dd7c4c3b2c8c74c99232 /packages/dsplink/dsplink.inc
parent4fe64e497bb8af2ca8298c7b5af3f52d68e0467d (diff)
dsplink: add glue to hook in TI dspbios and TI c64x compiler trees into the build
* The user needs to obtain dspbios and cgtools on its own and override the TI*DIR vars in local.conf to point to the correct location, default is /OE/TI
Diffstat (limited to 'packages/dsplink/dsplink.inc')
-rw-r--r--packages/dsplink/dsplink.inc16
1 files changed, 15 insertions, 1 deletions
diff --git a/packages/dsplink/dsplink.inc b/packages/dsplink/dsplink.inc
index d9c3c07e02..29633dae59 100644
--- a/packages/dsplink/dsplink.inc
+++ b/packages/dsplink/dsplink.inc
@@ -11,6 +11,13 @@ S = "${WORKDIR}/dsplink_1_50/dsplink"
# Needed for buildscripts
export DSPLINK = "${S}"
+# Path to the dir where the TI tools are unpacked
+TITOOLSDIR ?= "/OE/TI"
+# Path under TITOOLSDIR where dspbios is unpacked
+TIBIOSDIR ?= "bios_5_32_03"
+# Path under TITOOLSDIR where the dsp toolchain is unpacked
+TICGTOOLSDIR ?= "cg6x_6_1_2"
+
DSPLINKPLATFORM ?= "Davinci"
DSPLINKPLATFORM_omap5912osk = "OMAP"
@@ -48,6 +55,8 @@ KERNELARMFLAGS_armv7a = "-c -nostdinc -include $(BASE_OSINC)/linux/autoconf.h -i
-Wdeclaration-after-statement -Os -marm -mabi=aapcs-linux \
-D__KERNEL__ -mno-thumb-interwork -msoft-float -fno-optimize-sibling-calls -g -fno-stack-protector -Wno-pointer-sign -g -DUSE_UDEV=1 -DOS_LINUX -DLINUX_KERNEL"
+DSPFLAGS = "-q -pdr -pdv -pden -ml3 -mv64+ "
+
export DSPLINKPLATFORM
export DSPLINKDSP
@@ -59,7 +68,7 @@ do_configure () {
sed -i -e s:SED_ME_SOURCEDIR:${S}:g \
-e s:SED_ME_GPPDISTRO:openembedded:g \
-e s:SED_ME_KERNELVERSION:${KERNEL_VERSION}:g \
- -e s:SED_ME_DSPDISTRO:openembedded:g \
+ -e s:SED_ME_DSPDISTRO:c64xx_5.xx_linux:g \
-e s:SED_ME_PLATFORM:${DSPLINKPLATFORM}:g \
-e s:SED_ME_DSP:${DSPLINKDSP}:g \
-e s:SED_ME_SOC:${DSPLINKSOC}:g \
@@ -73,6 +82,11 @@ do_configure () {
-e 's:SEDME_USER_ARMFLAGS:${USERARMFLAGS}:g' \
${S}/make/Linux/openembedded.mk
+ sed -i -e s:SEDME_TITOOLS_BASEPATH:${TITOOLSDIR}:g \
+ -e s:SEDME_BIOSUNPACKDIR:${TIBIOSDIR}:g \
+ -e s:SEDME_CGTOOLSDIR:${TICGTOOLSDIR}:g \
+ -e 's:SEDME_DSPFLAGS:${DSPFLAGS}:g' \
+ ${S}/make/DspBios/c64xx_5.xx_linux.mk
}
PARALLEL_MAKE = ""