summaryrefslogtreecommitdiff
path: root/packages/directfb
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-06-18 13:59:14 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-06-18 13:59:14 +0000
commitb5192270e0aa3aaf3dc3e433cf6784fc3cc3efd1 (patch)
treeb22415f2e96af899d2408def5d3949c2ed21096d /packages/directfb
parentf8d4067156dfc4002c6e264c121fcbd72fe108ce (diff)
parentb939c070e77f85c850ae5af73e59ab25c476af24 (diff)
merge of '62e5c96415d18bfe68f153ce4fe1d0e39ad28384'
and '7fa9c991986febc368d168e9a8a8beb53388e4b8'
Diffstat (limited to 'packages/directfb')
-rw-r--r--packages/directfb/directfb_1.0.0.bb11
-rw-r--r--packages/directfb/files/fix-includes.patch24
2 files changed, 30 insertions, 5 deletions
diff --git a/packages/directfb/directfb_1.0.0.bb b/packages/directfb/directfb_1.0.0.bb
index cbeede90ab..caa8dbee8f 100644
--- a/packages/directfb/directfb_1.0.0.bb
+++ b/packages/directfb/directfb_1.0.0.bb
@@ -7,21 +7,22 @@ SECTION = "libs"
LICENSE = "LGPL"
HOMEPAGE = "http://directfb.org"
DEPENDS = "jpeg libpng freetype zlib tslib"
-PR = "r3"
+PR = "r4"
RV = "1.0-0"
SRC_URI = "http://www.directfb.org/download/DirectFB/DirectFB-${PV}.tar.gz \
file://fix-pkgconfig-specs.patch;patch=1 \
- file://mkdfiff.patch;patch=1 \
- file://getpagesize.patch;patch=1"
-
+ file://mkdfiff.patch;patch=1 \
+ file://getpagesize.patch;patch=1 \
+ file://fix-includes.patch;patch=1"
S = "${WORKDIR}/DirectFB-1.0.0"
LDFLAGS_append =" -lts -lm"
inherit autotools pkgconfig
-EXTRA_OECONF = "--with-gfxdrivers=none \
+EXTRA_OECONF = "\
+ --with-gfxdrivers=none \
--enable-libmpeg3=no \
--enable-freetype=yes \
--enable-sdl=no \
diff --git a/packages/directfb/files/fix-includes.patch b/packages/directfb/files/fix-includes.patch
new file mode 100644
index 0000000000..0c40cdb3a6
--- /dev/null
+++ b/packages/directfb/files/fix-includes.patch
@@ -0,0 +1,24 @@
+#
+# pkgconfig points to STAGING_INCDIR, hence
+# we need to append a directfb/ to make it
+# find its header files
+#
+# Signed-Off: mickey@openmoko.org
+#
+Index: DirectFB-1.0.0/include/directfb.h
+===================================================================
+--- DirectFB-1.0.0.orig/include/directfb.h
++++ DirectFB-1.0.0/include/directfb.h
+@@ -29,10 +29,10 @@
+ #ifndef __DIRECTFB_H__
+ #define __DIRECTFB_H__
+
+-#include <dfb_types.h>
++#include <directfb/dfb_types.h>
+ #include <sys/time.h> /* struct timeval */
+
+-#include <directfb_keyboard.h>
++#include <directfb/directfb_keyboard.h>
+
+ #ifdef __cplusplus
+ extern "C"