summaryrefslogtreecommitdiff
path: root/packages/directfb/++dfb_0.9.25.bb
diff options
context:
space:
mode:
authorShane Volpe <shanevolpe@gmail.com>2006-12-09 22:15:05 +0000
committerHolger Freyther <zecke@selfish.org>2006-12-09 22:15:05 +0000
commitb21d9ec51682078eac434f20b064cf63a4722c36 (patch)
tree208a04b081c39f29aa4bbd5281eafbfaea9b1ba6 /packages/directfb/++dfb_0.9.25.bb
parent3ee8fa7b3192fbc2b0cdb52fc7f4298c8f22057e (diff)
packages/directfb: Add rc2 of directfb from #1618 by <shanevolpe@gmail.com>
Drop the old unfetchable versions of directFB and replace them with the shiny rc2 of directFB. This patch is from #1618 by Shane Volpe and adds tslib support to directFB.
Diffstat (limited to 'packages/directfb/++dfb_0.9.25.bb')
-rw-r--r--packages/directfb/++dfb_0.9.25.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/directfb/++dfb_0.9.25.bb b/packages/directfb/++dfb_0.9.25.bb
new file mode 100644
index 0000000000..f440e117ff
--- /dev/null
+++ b/packages/directfb/++dfb_0.9.25.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "A C++ Wrapper for the directfb framebuffer library."
+HOMEPAGE = "http://directfb.org"
+SECTION = "libs"
+DEPENDS = "directfb"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.directfb.org/downloads/Extras/++DFB-${PV}.tar.gz"
+S = "${WORKDIR}/++DFB-${PV}"
+RV = "0.9-25"
+
+inherit autotools pkgconfig
+
+do_configure_append() {
+ find ${S} -type f | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:'
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+FILES_++dfb_append = " ${libdir}/*.so*"