summaryrefslogtreecommitdiff
path: root/packages/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch
diff options
context:
space:
mode:
authorErik Hovland <erik@hovland.org>2006-08-30 18:42:42 +0000
committerErik Hovland <erik@hovland.org>2006-08-30 18:42:42 +0000
commit4d36c0d6c6c4e6ed9f148d70588fdb16798e9b9c (patch)
treee1e2d433887f193ea6be861ece68309e7d667619 /packages/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch
parentff49b42aedb3c09f71cb35456140b9afcf6b40b8 (diff)
parent71bd0cd9cf4addbc38028705674fb56c2a644071 (diff)
merge of 'd0e2c30b999cbef32c26717651606b8411ad02d6'
and 'ffac2606c1f6116f54c1871ff55c69f027252547'
Diffstat (limited to 'packages/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch')
-rw-r--r--packages/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch b/packages/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch
new file mode 100644
index 0000000000..c2e2151d17
--- /dev/null
+++ b/packages/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch
@@ -0,0 +1,26 @@
+diff -Naur dhcdbd-1.14/Makefile dhcdbd-1.14-mod/Makefile
+--- dhcdbd-1.14/Makefile 2006-01-17 22:23:51.000000000 +0100
++++ dhcdbd-1.14-mod/Makefile 2006-08-02 18:02:42.000000000 +0200
+@@ -7,8 +7,8 @@
+ LDFLAGS ?= -g
+ DESTDIR ?= /
+ LIBDIR ?= lib
+-DBUS_INCLUDES ?= -I/usr/$(LIBDIR)/dbus-1.0/include -I/usr/include/dbus-1.0
+-DBUS_LIBS ?= -ldbus-1
++DBUS_INCLUDES ?= `pkg-config dbus-1 --cflags`
++DBUS_LIBS ?= `pkg-config dbus-1 --libs`
+ OBJS = dbus_service.o dhcdbd.o dhcp_options.o main.o
+ SRCS = dbus_service.c dhcdbd.c dhcp_options.c main.c
+ INCS = dbus_service.h dhcdbd.h dhcp_options.h includes.h
+diff -Naur dhcdbd-1.14/tests/Makefile dhcdbd-1.14-mod/tests/Makefile
+--- dhcdbd-1.14/tests/Makefile 2006-01-17 22:23:51.000000000 +0100
++++ dhcdbd-1.14-mod/tests/Makefile 2006-08-02 18:11:43.000000000 +0200
+@@ -2,7 +2,7 @@
+ LD = ${CC}
+ CFLAGS ?= -g -Wall
+ LDFLAGS ?= -g
+-DBUS_LIBS ?= -ldbus-1
++DBUS_LIBS ?= `pkg-config dbus-1 --libs`
+
+ all: test_dhcp_options test_dhcdbd_state test_subscriber test_subscriber_dbus test_prospective_subscriber
+