summaryrefslogtreecommitdiff
path: root/packages/dbus/dbus-glib-native/run-with-tmp-session-bus.patch
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-08-27 17:20:35 +0000
committerGraeme Gregory <dp@xora.org.uk>2006-08-27 17:20:35 +0000
commit69383bc09ea895755f1ed236c686e5c6cdf9ced7 (patch)
tree79debc84d115e3331af9e384af855e5dfdb25d2c /packages/dbus/dbus-glib-native/run-with-tmp-session-bus.patch
parentb59ce10791fa913ef0915e48a514f04ca2815977 (diff)
parent2ef9cf97f34b7ec69f1df908413afa462e09ba61 (diff)
merge of '31791b517fd0fdc4e50c48d20a836408a23727d3'
and 'ce3b6559d2cb3ba65a6dd0f69e76c890fe48f129'
Diffstat (limited to 'packages/dbus/dbus-glib-native/run-with-tmp-session-bus.patch')
-rw-r--r--packages/dbus/dbus-glib-native/run-with-tmp-session-bus.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/packages/dbus/dbus-glib-native/run-with-tmp-session-bus.patch b/packages/dbus/dbus-glib-native/run-with-tmp-session-bus.patch
new file mode 100644
index 0000000000..186abdb56b
--- /dev/null
+++ b/packages/dbus/dbus-glib-native/run-with-tmp-session-bus.patch
@@ -0,0 +1,32 @@
+--- dbus-glib-0.71/tools/Makefile.am.orig 2006-08-27 12:54:34.351198198 +0200
++++ dbus-glib-0.71/tools/Makefile.am 2006-08-27 12:55:12.533584373 +0200
+@@ -9,7 +9,7 @@
+ BUILT_SOURCES = dbus-glib-bindings.h dbus-bus-introspect.xml
+
+ dbus-bus-introspect.xml:
+- DBUS_TOP_BUILDDIR=$(top_builddir) dbus-send --system --print-reply=literal --dest=org.freedesktop.DBus /org/freedesktop/DBus org.freedesktop.DBus.Introspectable.Introspect > dbus-bus-introspect.xml.tmp && mv dbus-bus-introspect.xml.tmp dbus-bus-introspect.xml
++ DBUS_TOP_BUILDDIR=$(top_builddir) ./run-with-tmp-session-bus.sh dbus-send --print-reply=literal --dest=org.freedesktop.DBus /org/freedesktop/DBus org.freedesktop.DBus.Introspectable.Introspect > dbus-bus-introspect.xml.tmp && mv dbus-bus-introspect.xml.tmp dbus-bus-introspect.xml
+
+ EXTRA_DIST = run-with-tmp-session-bus.sh
+
+--- dbus-glib-0.71/tools/run-with-tmp-session-bus.sh.orig 2006-08-27 11:52:17.497666746 +0200
++++ dbus-glib-0.71/tools/run-with-tmp-session-bus.sh 2006-08-27 12:53:22.626715838 +0200
+@@ -27,16 +27,15 @@
+ echo "escaped service dir is: $ESCAPED_SERVICE_DIR" >&2
+
+ ## create a configuration file based on the standard session.conf
+-cat $DBUS_TOP_BUILDDIR/tools/session.conf | \
++cat $datadir/dbus/session.conf | \
+ sed -e 's/<servicedir>.*$/<servicedir>'$ESCAPED_SERVICE_DIR'<\/servicedir>/g' | \
+ sed -e 's/<include.*$//g' \
+ > $CONFIG_FILE
+
+ echo "Created configuration file $CONFIG_FILE" >&2
+
+-export PATH=$DBUS_TOP_BUILDDIR/bus:$PATH
+ ## the libtool script found by the path search should already do this, but
+-export LD_LIBRARY_PATH=$DBUS_TOP_BUILDDIR/dbus/.libs:$LD_LIBRARY_PATH
++export LD_LIBRARY_PATH=$libdir:$LD_LIBRARY_PATH
+
+ unset DBUS_SESSION_BUS_ADDRESS
+ unset DBUS_SESSION_BUS_PID