summaryrefslogtreecommitdiff
path: root/packages/cpusage
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/cpusage
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/cpusage')
-rw-r--r--packages/cpusage/cpusage-0.1/cpusage.patch63
-rw-r--r--packages/cpusage/cpusage_0.1.bb24
-rw-r--r--packages/cpusage/cpusage_0.2.bb24
3 files changed, 0 insertions, 111 deletions
diff --git a/packages/cpusage/cpusage-0.1/cpusage.patch b/packages/cpusage/cpusage-0.1/cpusage.patch
deleted file mode 100644
index 091c7a9817..0000000000
--- a/packages/cpusage/cpusage-0.1/cpusage.patch
+++ /dev/null
@@ -1,63 +0,0 @@
---- /orig-cpusage.c 2005-08-16 15:37:25.000000000 +0300
-+++ /cpusage.c 2006-03-17 22:27:09.000000000 +0200
-@@ -168,6 +168,7 @@
- int main(int argc, char** argv) {
-
- int i,c,limit;
-+ int single; /* run just one's and exit */
- int avg; /* is avg measurement allready running */
- int avg_run; /* did we allready had an avg measurement */
- static long cp_time1[CPUSTATES];
-@@ -184,15 +185,21 @@
- long total;
- limit = LIMIT;
- output = 0; /* human readable */
-+ single = 1; /*run continuesly */
-
- /* reading commandline options */
- while (1) {
-- c = getopt(argc, argv, "aohl:");
-+ c = getopt(argc, argv, "saohl:");
-
-- if (c == -1)
-+ if (c == -1){
- break;
-+ }
-
- switch(c){
-+ case 's':
-+ /*run once and exit */
-+ single = 0;
-+ break;
- /* use avg from begin to end -> same as "-l 100" */
- case 'a':
- limit = 100;
-@@ -278,6 +285,10 @@
-
- print_perc(cpu_perc, "");
-
-+ if (!single ) {
-+ breakloop=1;
-+ }
-+
- if (breakloop) {
- if (avg) {
- avg = 0;
-@@ -292,7 +303,8 @@
- if (sigaction(SIGINT, &sigold, &signew) < 0 ){
- fprintf(stderr, "Could not restore signal handler -> exiting");
- }
--
-+
-+ if (single != 0) {
- printf("---Summary----\n");
-
- print_perc(cpu_min, "Min");
-@@ -301,6 +313,7 @@
-
- perc(CPUSTATES, cp_avg_start, cp_avg_stop, cp_diff);
- print_perc(cpu_perc, "Avg");
-+ }
-
- return 0;
- }
diff --git a/packages/cpusage/cpusage_0.1.bb b/packages/cpusage/cpusage_0.1.bb
deleted file mode 100644
index d90c630ceb..0000000000
--- a/packages/cpusage/cpusage_0.1.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION = "This tool read out the tics counter of the operating system and \
-calculates the Percentages spend in each CPU_STATE."
-SECTION = "base"
-PRIORITY = "optional"
-LICENSE = "GPL"
-
-SRC_URI = "http://www8.in.tum.de/~schneifa/group/sources/cpusage-${PV}.tar.gz \
- file://cpusage.patch;patch=1"
-
-S = "${WORKDIR}/cpusage-${PV}"
-
-FILES_${PN} = "/sbin/cpusage"
-
-CFLAGS_append =" -D_BSD_SOURCE=1"
-CFLAGS_append = '${@base_conditional("KERNEL_MAJOR_VERSION", "2.6", " -D__Linux26__ ", " -D__Linux24__ ",d)}'
-
-do_compile() {
- ${CC} ${CFLAGS} ${LDFLAGS} -o cpusage cpusage.c
-}
-
-do_install() {
- install -d ${D}${base_sbindir}
- install -m 0755 cpusage ${D}${base_sbindir}/cpusage
-}
diff --git a/packages/cpusage/cpusage_0.2.bb b/packages/cpusage/cpusage_0.2.bb
deleted file mode 100644
index 7d4df4eccf..0000000000
--- a/packages/cpusage/cpusage_0.2.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION = "This tool read out the tics counter of the operating system and \
-calculates the Percentages spend in each CPU_STATE."
-SECTION = "base"
-PRIORITY = "optional"
-LICENSE = "GPL"
-
-SRC_URI = "http://www8.in.tum.de/~schneifa/group/sources/cpusage-${PV}.tar.gz"
-
-S = "${WORKDIR}/cpusage-${PV}"
-
-FILES_${PN} = "/sbin/cpusage"
-
-CFLAGS_append =" -D_BSD_SOURCE=1"
-CFLAGS_append = '${@base_conditional("KERNEL_MAJOR_VERSION", "2.6", " -D__Linux26__ ", " -D__Linux24__ ",d)}'
-
-
-do_compile() {
- ${CC} ${CFLAGS} ${LDFLAGS} -o cpusage cpusage.c
-}
-
-do_install() {
- install -d ${D}${base_sbindir}
- install -m 0755 cpusage ${D}${base_sbindir}/cpusage
-}