summaryrefslogtreecommitdiff
path: root/packages/connman/files
diff options
context:
space:
mode:
authorJulian_chu <julian_chu@openmoko.com>2008-09-18 17:06:10 +0800
committerHolger Hans Peter Freyther <zecke@selfish.org>2008-10-15 20:37:47 +0200
commitaed1f4ad670dbcc2bd47a83c7968d1a883acdfab (patch)
tree1ff7a3246573767b6f55e54613918f2525eaf24c /packages/connman/files
parent7a4455feaa846794343594376bcedadb008cbd38 (diff)
[connman] Upgrade connman to latest revision.
connman use native _nm_ to list symbols. However, it may cause problem when cross compiling. Add a patch to use cross-tools if set host=$SOMETHING when do configure.
Diffstat (limited to 'packages/connman/files')
-rw-r--r--packages/connman/files/use_nm_in_cross_compiling.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/packages/connman/files/use_nm_in_cross_compiling.patch b/packages/connman/files/use_nm_in_cross_compiling.patch
new file mode 100644
index 0000000000..e9f2b29e3e
--- /dev/null
+++ b/packages/connman/files/use_nm_in_cross_compiling.patch
@@ -0,0 +1,17 @@
+Index: git/src/Makefile.am
+===================================================================
+--- git.orig/src/Makefile.am 2008-09-18 16:48:44.000000000 +0800
++++ git/src/Makefile.am 2008-09-18 16:49:54.000000000 +0800
+@@ -44,7 +44,11 @@
+ MAINTAINERCLEANFILES = Makefile.in
+
+ connman.exp:
+- nm -B *.o | awk '{ print $$3 }' | sort -u | grep -E -e '^connman_' > $@
++ if test -n $$host ; then \
++ $(host)-nm -B *.o | awk '{ print $$3 }' | sort -u | grep -E -e '^connman_' > $@ ;\
++ else \
++ nm -B *.o | awk '{ print $$3 }' | sort -u | grep -E -e '^connman_' > $@ ;\
++ fi
+
+ connman.ver: connman.exp
+ echo "{ global:" > $@