summaryrefslogtreecommitdiff
path: root/packages/busybox/busybox_1.2.0.bb
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2006-12-19 12:53:30 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2006-12-19 12:53:30 +0000
commit378b7ec5b0c5dd38ec0d7d4e69c4078e6c22acca (patch)
treef9ea136bfc0c995ec8f0d72e7ba4875bea1577da /packages/busybox/busybox_1.2.0.bb
parent7c45c11af2e21babb3a4a12db9522cffb5893fa7 (diff)
busybox: unify
Diffstat (limited to 'packages/busybox/busybox_1.2.0.bb')
-rw-r--r--packages/busybox/busybox_1.2.0.bb74
1 files changed, 3 insertions, 71 deletions
diff --git a/packages/busybox/busybox_1.2.0.bb b/packages/busybox/busybox_1.2.0.bb
index d537406d08..a4157082e8 100644
--- a/packages/busybox/busybox_1.2.0.bb
+++ b/packages/busybox/busybox_1.2.0.bb
@@ -1,63 +1,11 @@
-DESCRIPTION = "BusyBox combines tiny versions of many common UNIX utilities into a single \
-small executable. It provides minimalist replacements for most of the \
-utilities you usually find in GNU fileutils, shellutils, etc. The utilities \
-in BusyBox generally have fewer options than their full-featured GNU \
-cousins; however, the options that are included provide the expected \
-functionality and behave very much like their GNU counterparts. BusyBox \
-provides a fairly complete POSIX environment for any small or embedded \
-system."
-HOMEPAGE = "http://www.busybox.net"
-LICENSE = "GPL"
-SECTION = "base"
-PRIORITY = "required"
-PR = "r1"
+require busybox.inc
-SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
-# file://udhcppidfile.patch;patch=1 \
-# file://udhcppidfile-breakage.patch;patch=1 \
-# file://below.patch;patch=1 \
- file://dhcp-hostname.patch;patch=1 \
-# file://fbset.patch;patch=1 \
-# file://hdparm_M.patch;patch=1 \
- file://ifupdown-spurious-environ.patch;patch=1 \
-# file://mount-all-type.patch;patch=1 \
-# file://rmmod.patch;patch=1 \
- file://udhcpscript.patch;patch=1 \
- file://defconfig \
- file://busybox-cron \
- file://busybox-httpd \
- file://busybox-udhcpd \
- file://syslog \
- file://hwclock.sh \
- file://default.script \
- file://syslog.conf \
- file://mount.busybox \
- file://umount.busybox"
+PR = "r1"
-SRC_URI_append_nylon = " file://xargs-double-size.patch;patch=1"
+SRC_URI += "file://defconfig"
S = "${WORKDIR}/busybox-1.2.0"
-export EXTRA_CFLAGS = "${CFLAGS}"
-EXTRA_OEMAKE_append = " CROSS=${HOST_PREFIX}"
-PACKAGES =+ "${PN}-httpd ${PN}-udhcpd"
-
-FILES_${PN}-httpd = "${sysconfdir}/init.d/busybox-httpd /srv/www"
-FILES_${PN}-udhcpd = "${sysconfdir}/init.d/busybox-udhcpd"
-
-FILES_${PN} += " ${datadir}/udhcpc"
-
-INITSCRIPT_PACKAGES = "${PN} ${PN}-httpd ${PN}-udhcpd"
-INITSCRIPT_NAME_${PN}-httpd = "busybox-httpd"
-INITSCRIPT_NAME_${PN}-udhcpd = "busybox-udhcpd"
-INITSCRIPT_NAME_${PN} = "syslog"
-CONFFILES_${PN} = "${sysconfdir}/syslog.conf"
-
-# This disables the syslog startup links in openslug (see openslug-init)
-INITSCRIPT_PARAMS_${PN}_openslug = "start 20 ."
-
-inherit cml1 update-rc.d
-
do_configure () {
install -m 0644 ${WORKDIR}/defconfig ${S}/.config.oe
@@ -70,11 +18,6 @@ do_configure () {
cml1_do_configure
}
-do_compile () {
- unset CFLAGS
- base_do_compile
-}
-
do_install () {
install -d ${D}${sysconfdir}/init.d
oe_runmake "PREFIX=${D}" install
@@ -136,17 +79,6 @@ do_install () {
install -m 0644 ${S}/busybox.links ${D}${sysconfdir}
}
-pkg_postinst_${PN} () {
- # If we are not making an image we create links for the utilities that doesn't exist
- # so the update-alternatives script will get the utilities it needs
- # (update-alternatives have no problem replacing links later anyway)
- test -n 2> /dev/null || alias test='busybox test'
- if test "x$D" = "x"; then while read link; do if test ! -h "$link"; then case "$link" in /*/*/*) to="../../bin/busybox";; /bin/*) to="busybox";; /*/*) to="../bin/busybox";; esac; busybox ln -s $to $link; fi; done </etc/busybox.links; fi
-
- # This adds the links, remember that this has to work when building an image too, hence the $D
- while read link; do case "$link" in /*/*/*) to="../../bin/busybox";; /bin/*) to="busybox";; /*/*) to="../bin/busybox";; esac; bn=`basename $link`; update-alternatives --install $link $bn $to 50; done <$D/etc/busybox.links
-}
-
pkg_prerm_${PN} () {
# This is so you can make busybox commit suicide - removing busybox with no other packages
# providing its files, this will make update-alternatives work, but the update-rc.d part