summaryrefslogtreecommitdiff
path: root/packages/btsco/btsco-module_0.42.bb
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@yahoo.com>2006-05-20 19:33:32 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-20 19:33:32 +0000
commit6c0dddae8f2478c1bd7fc80ab05833d77eefd369 (patch)
tree24a44a0d44681b601d76eb71f74386ad20c4f865 /packages/btsco/btsco-module_0.42.bb
parent513a6ae1b6c0602cdb5d112586c13eb539fcd5cd (diff)
btsco: added bb files for 0.42
Diffstat (limited to 'packages/btsco/btsco-module_0.42.bb')
-rw-r--r--packages/btsco/btsco-module_0.42.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/btsco/btsco-module_0.42.bb b/packages/btsco/btsco-module_0.42.bb
new file mode 100644
index 0000000000..68c13a33d0
--- /dev/null
+++ b/packages/btsco/btsco-module_0.42.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Bluetooth-alsa headset module"
+SECTION = "kernel/modules"
+HOMEPAGE = "http://bluetooth-alsa.sourceforge.net/"
+LICENSE = "GPL"
+DEPENDS = "alsa-lib bluez-libs"
+PR = "r0"
+
+inherit module
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/bluetooth-alsa/btsco-${PV}.tar.gz \
+ file://makefile.patch;patch=1"
+
+S = "${WORKDIR}/btsco-${PV}/kernel"
+
+MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make -e'"
+
+do_install() {
+ install -m 0755 -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra
+ install -m 0644 ${S}/snd-bt-sco${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra/
+}