summaryrefslogtreecommitdiff
path: root/packages/boost
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-11-30 10:53:57 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-30 10:53:57 +0000
commit32a7d2a5419b88a97d291492d729b88e6274036d (patch)
tree50b3cf924e2133063efcbff192768534d7064755 /packages/boost
parentb5412bb66cce8ba7780cfe7233056474c4bd4ccc (diff)
boost-jam-native: release 3.1.11
boost: release 1.33.0
Diffstat (limited to 'packages/boost')
-rw-r--r--packages/boost/boost-jam-native_3.1.11.bb (renamed from packages/boost/boost-jam-native_3.1.10.bb)6
-rw-r--r--packages/boost/boost_1.33.0.bb (renamed from packages/boost/boost_1.32.0.bb)31
2 files changed, 24 insertions, 13 deletions
diff --git a/packages/boost/boost-jam-native_3.1.10.bb b/packages/boost/boost-jam-native_3.1.11.bb
index 3a844b191e..cf9f2317c8 100644
--- a/packages/boost/boost-jam-native_3.1.10.bb
+++ b/packages/boost/boost-jam-native_3.1.11.bb
@@ -27,9 +27,5 @@ do_compile() {
# rely on only one bin.foo directory being created.
do_stage() {
set -ex
- install -c -m 755 bin.*/jam ${STAGING_BINDIR}/
- install -c -m 755 bin.*/mkjambase ${STAGING_BINDIR}/
- install -c -m 755 bin.*/yyacc ${STAGING_BINDIR}/
- rm -f ${STAGING_BINDIR}/bjam
- ln -sf ./jam ${STAGING_BINDIR}/bjam
+ install -c -m 755 bin.*/bjam ${STAGING_BINDIR}/
}
diff --git a/packages/boost/boost_1.32.0.bb b/packages/boost/boost_1.33.0.bb
index a844fac4cf..2c81f37899 100644
--- a/packages/boost/boost_1.32.0.bb
+++ b/packages/boost/boost_1.33.0.bb
@@ -7,10 +7,10 @@ DESCRIPTION = "Free peer-reviewed portable C++ source libraries"
HOMEPAGE = "http://www.boost.org/"
MAINTAINER = "John Bowler <jbowler@acm.org>"
SECTION = "libs"
-DEPENDS = "boost-jam-native"
+DEPENDS = "boost-jam-native zlib"
PRIORITY = "optional"
LICENSE = "Boost Software License"
-PR = "r1"
+PR = "r0"
# need debian package naming for the libs
inherit debian
@@ -18,10 +18,9 @@ inherit debian
BOOST_VER = "${@"_".join(bb.data.getVar("PV",d,1).split("."))}"
BOOST_MAJ = "${@"_".join(bb.data.getVar("PV",d,1).split(".")[0:2])}"
BOOST_P = "boost_${BOOST_VER}"
-SRC_URI = "${SOURCEFORGE_MIRROR}/boost/${BOOST_P}.tar.bz2 \
- file://unit_test_log10f.patch;patch=1 \
- file://linux-uclibc.patch;patch=1 \
- "
+SRC_URI = "${SOURCEFORGE_MIRROR}/boost/${BOOST_P}.tar.bz2"
+#SRC_URI += "file://unit_test_log10f.patch;patch=1"
+SRC_URI += "file://linux-uclibc.patch;patch=1"
S = "${WORKDIR}/${BOOST_P}"
@@ -55,6 +54,15 @@ FILES_boost-thread-mt = "${libdir}/libboost_thread-mt.so.${PV}"
PACKAGES += "boost-unit-test-framework"
FILES_boost-unit-test-framework = "${libdir}/libboost_unit_test_framework.so.${PV}"
+PACKAGES += "boost-iostreams"
+FILES_boost-iostreams = "${libdir}/libboost_iostreams.so.${PV}"
+
+PACKAGES += "boost-serialization"
+FILES_boost-serialization = "${libdir}/libboost_serialization.so.${PV}"
+
+PACKAGES += "boost-wserialization"
+FILES_boost-wserialization = "${libdir}/libboost_wserialization.so.${PV}"
+
# Python - remove this and set:
#PYTHON_ROOT = "/dev/null"
# to remove the python build
@@ -99,12 +107,19 @@ EQD = '\"'
#boost.bb: "... '-sGCC=... '${SQD}'-DBOOST_PLATFORM_CONFIG=${EQD}config${EQD}'${SQD} ..."
BJAM_CONF = "${SQD}'-DBOOST_PLATFORM_CONFIG=${EQD}boost/config/platform/${TARGET_OS}.hpp${EQD}'${SQD}"
+# bzip2 and zip are disabled because... they're broken - the compilation simply
+# isn't working with bjam. I guess they will fix it, but who needs it? This
+# only affects the (new in 33) iostream library.
BJAM_TOOLS = "-sTOOLS=gcc \
'-sGCC=${CC} '${BJAM_CONF} \
'-sGXX=${CXX} '${BJAM_CONF} \
- -sBUILD='release <optimization>space <inlining>on <debug-symbols>off' \
+ '-sGCC_INCLUDE_DIRECTORY=${STAGING_INCDIR}' \
+ '-sGCC_STDLIB_DIRECTORY=${STAGING_LIBDIR}' \
+ '-sNO_BZIP2=1' \
+ '-sNO_ZLIB=1' \
+ '-sBUILD=release <optimization>space <inlining>on <debug-symbols>off' \
'-sPYTHON_VERSION=${PYTHON_VERSION}' \
- --layout=system \
+ '--layout=system' \
"
BJAM_OPTS = '${BJAM_TOOLS} \