From 32a7d2a5419b88a97d291492d729b88e6274036d Mon Sep 17 00:00:00 2001
From: John Bowler <jbowler@nslu2-linux.org>
Date: Wed, 30 Nov 2005 10:53:57 +0000
Subject: boost-jam-native: release 3.1.11 boost: release 1.33.0

---
 packages/boost/boost-jam-native_3.1.10.bb |  35 -------
 packages/boost/boost-jam-native_3.1.11.bb |  31 ++++++
 packages/boost/boost_1.32.0.bb            | 138 ---------------------------
 packages/boost/boost_1.33.0.bb            | 153 ++++++++++++++++++++++++++++++
 4 files changed, 184 insertions(+), 173 deletions(-)
 delete mode 100644 packages/boost/boost-jam-native_3.1.10.bb
 create mode 100644 packages/boost/boost-jam-native_3.1.11.bb
 delete mode 100644 packages/boost/boost_1.32.0.bb
 create mode 100644 packages/boost/boost_1.33.0.bb

(limited to 'packages/boost')

diff --git a/packages/boost/boost-jam-native_3.1.10.bb b/packages/boost/boost-jam-native_3.1.10.bb
deleted file mode 100644
index 3a844b191e..0000000000
--- a/packages/boost/boost-jam-native_3.1.10.bb
+++ /dev/null
@@ -1,35 +0,0 @@
-# The Boost web site provides free peer-reviewed portable
-# C++ source libraries. The emphasis is on libraries which
-# work well with the C++ Standard Library. The libraries are
-# intended to be widely useful, and are in regular use by
-# thousands of programmers across a broad spectrum of applications.
-DESCRIPTION = "Make system for boost (native)"
-HOMEPAGE = "http://www.boost.org/"
-MAINTAINER = "John Bowler <jbowler@acm.org>"
-SECTION = "devel"
-PRIORITY = "optional"
-LICENSE = "Boost Software License"
-PR = "r0"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/boost/boost-jam-${PV}.tgz"
-S = "${WORKDIR}/boost-jam-${PV}"
-
-inherit native
-
-do_compile() {
-	set -ex
-	rm -rf bin.*
-	./build.sh gcc
-}
-
-# This is too terrible - the build script doesn't give any good
-# way I can see to find out where the binaries are placed, so
-# rely on only one bin.foo directory being created.
-do_stage() {
-	set -ex
-	install -c -m 755 bin.*/jam ${STAGING_BINDIR}/
-	install -c -m 755 bin.*/mkjambase ${STAGING_BINDIR}/
-	install -c -m 755 bin.*/yyacc ${STAGING_BINDIR}/
-	rm -f ${STAGING_BINDIR}/bjam
-	ln -sf ./jam ${STAGING_BINDIR}/bjam
-}
diff --git a/packages/boost/boost-jam-native_3.1.11.bb b/packages/boost/boost-jam-native_3.1.11.bb
new file mode 100644
index 0000000000..cf9f2317c8
--- /dev/null
+++ b/packages/boost/boost-jam-native_3.1.11.bb
@@ -0,0 +1,31 @@
+# The Boost web site provides free peer-reviewed portable
+# C++ source libraries. The emphasis is on libraries which
+# work well with the C++ Standard Library. The libraries are
+# intended to be widely useful, and are in regular use by
+# thousands of programmers across a broad spectrum of applications.
+DESCRIPTION = "Make system for boost (native)"
+HOMEPAGE = "http://www.boost.org/"
+MAINTAINER = "John Bowler <jbowler@acm.org>"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "Boost Software License"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/boost/boost-jam-${PV}.tgz"
+S = "${WORKDIR}/boost-jam-${PV}"
+
+inherit native
+
+do_compile() {
+	set -ex
+	rm -rf bin.*
+	./build.sh gcc
+}
+
+# This is too terrible - the build script doesn't give any good
+# way I can see to find out where the binaries are placed, so
+# rely on only one bin.foo directory being created.
+do_stage() {
+	set -ex
+	install -c -m 755 bin.*/bjam ${STAGING_BINDIR}/
+}
diff --git a/packages/boost/boost_1.32.0.bb b/packages/boost/boost_1.32.0.bb
deleted file mode 100644
index a844fac4cf..0000000000
--- a/packages/boost/boost_1.32.0.bb
+++ /dev/null
@@ -1,138 +0,0 @@
-# The Boost web site provides free peer-reviewed portable
-# C++ source libraries. The emphasis is on libraries which
-# work well with the C++ Standard Library. The libraries are
-# intended to be widely useful, and are in regular use by
-# thousands of programmers across a broad spectrum of applications.
-DESCRIPTION = "Free peer-reviewed portable C++ source libraries"
-HOMEPAGE = "http://www.boost.org/"
-MAINTAINER = "John Bowler <jbowler@acm.org>"
-SECTION = "libs"
-DEPENDS = "boost-jam-native"
-PRIORITY = "optional"
-LICENSE = "Boost Software License"
-PR = "r1"
-
-# need debian package naming for the libs
-inherit debian
-
-BOOST_VER = "${@"_".join(bb.data.getVar("PV",d,1).split("."))}"
-BOOST_MAJ = "${@"_".join(bb.data.getVar("PV",d,1).split(".")[0:2])}"
-BOOST_P = "boost_${BOOST_VER}"
-SRC_URI = "${SOURCEFORGE_MIRROR}/boost/${BOOST_P}.tar.bz2 \
-		file://unit_test_log10f.patch;patch=1 \
-		file://linux-uclibc.patch;patch=1 \
-		"
-
-S = "${WORKDIR}/${BOOST_P}"
-
-# Make a package for each library, plus -dev and -python
-PACKAGES =
-
-PACKAGES += "boost-date-time"
-FILES_boost-date-time = "${libdir}/libboost_date_time.so.${PV}"
-
-PACKAGES += "boost-filesystem"
-FILES_boost-filesystem = "${libdir}/libboost_filesystem.so.${PV}"
-
-PACKAGES += "boost-prg-exec-monitor"
-FILES_boost-prg-exec-monitor = "${libdir}/libboost_prg_exec_monitor.so.${PV}"
-
-PACKAGES += "boost-program-options"
-FILES_boost-program-options = "${libdir}/libboost_program_options.so.${PV}"
-
-PACKAGES += "boost-regex"
-FILES_boost-regex = "${libdir}/libboost_regex.so.${PV}"
-
-PACKAGES += "boost-signals"
-FILES_boost-signals = "${libdir}/libboost_signals.so.${PV}"
-
-PACKAGES += "boost-test-exec-monitor"
-FILES_boost-test-exec-monitor = "${libdir}/libboost_test_exec_monitor.so.${PV}"
-
-PACKAGES += "boost-thread-mt"
-FILES_boost-thread-mt = "${libdir}/libboost_thread-mt.so.${PV}"
-
-PACKAGES += "boost-unit-test-framework"
-FILES_boost-unit-test-framework = "${libdir}/libboost_unit_test_framework.so.${PV}"
-
-# Python - remove this and set:
-#PYTHON_ROOT = "/dev/null"
-# to remove the python build
-DEPENDS += "python"
-PYTHON_ROOT = "${STAGING_DIR}/${HOST_SYS}"
-PYTHON_VERSION = "2.4"
-
-PACKAGES += "boost-python"
-FILES_boost-python = "${libdir}/libboost_python.so.${PV}"
-
-# -dev last to pick up the remaining stuff
-PACKAGES += "${PN}-dev"
-FILES_${PN}-dev = "${includedir} ${libdir}/libboost_*.so ${libdir}/libboost_*.a"
-
-# Oh yippee, a new build system, it's sooo cooool I could eat my own
-# foot.  inlining=on lets the compiler choose, I think.  At least this
-# stuff is documented...
-# NOTE: if you leave <debug-symbols>on then in a debug build the build sys
-# objcopy will be invoked, and that won't work.  Building debug apparently
-# requires hacking gcc-tools.jam
-#
-# Sometimes I wake up screaming.  Famous figures are gathered in the nightmare,
-# Steve Bourne, Larry Wall, the whole of the ANSI C committee.  They're just
-# standing there, waiting, but the truely terrifying thing is what they carry
-# in their hands.  At first sight each seems to bear the same thing, but it is
-# not so for the forms in their grasp are ever so slightly different one from
-# the other.  Each is twisted in some grotesque way from the other to make each
-# an unspeakable perversion impossible to perceive without the onset of madness.
-# True insanity awaits anyone who perceives all of these horrors together.
-#
-# Quotation marks, there might be an easier way to do this, but I can't find
-# it.  The problem is that the user.hpp configuration file must receive a
-# pre-processor macro defined as the appropriate string - complete with "'s
-# around it.  (<> is a possibility here but the danger to that is that the
-# failure case interprets the < and > as shell redirections, creating 
-# random files in the source tree.)
-#
-#bjam: '-DBOOST_PLATFORM_CONFIG=\"config\"'
-#do_compile: '-sGCC=... '"'-DBOOST_PLATFORM_CONFIG=\"config\"'"
-SQD = '"'
-EQD = '\"'
-#boost.bb:   "...  '-sGCC=... '${SQD}'-DBOOST_PLATFORM_CONFIG=${EQD}config${EQD}'${SQD} ..."
-BJAM_CONF = "${SQD}'-DBOOST_PLATFORM_CONFIG=${EQD}boost/config/platform/${TARGET_OS}.hpp${EQD}'${SQD}"
-
-BJAM_TOOLS   = "-sTOOLS=gcc \
-		'-sGCC=${CC} '${BJAM_CONF} \
-		'-sGXX=${CXX} '${BJAM_CONF} \
-		-sBUILD='release <optimization>space <inlining>on <debug-symbols>off' \
-		'-sPYTHON_VERSION=${PYTHON_VERSION}' \
-		--layout=system \
-		"
-
-BJAM_OPTS    = '${BJAM_TOOLS} \
-		--builddir=${S}/${TARGET_SYS} \
-		--with-python-root=${PYTHON_ROOT} \
-		${BJAM_EXTRA}'
-
-
-do_compile() {
-	set -ex
-	bjam ${BJAM_OPTS} --prefix=${prefix} \
-		--exec-prefix=${exec_prefix} \
-		--libdir=${libdir} \
-		--includedir=${includedir}
-}
-
-do_stage() {
-	set -ex
-	bjam ${BJAM_OPTS} \
-		--libdir=${STAGING_LIBDIR} \
-		--includedir=${STAGING_INCDIR} \
-		install
-}
-
-do_install() {
-	set -ex
-	bjam ${BJAM_OPTS} \
-		--libdir=${D}${libdir} \
-		--includedir=${D}${includedir} \
-		install
-}
diff --git a/packages/boost/boost_1.33.0.bb b/packages/boost/boost_1.33.0.bb
new file mode 100644
index 0000000000..2c81f37899
--- /dev/null
+++ b/packages/boost/boost_1.33.0.bb
@@ -0,0 +1,153 @@
+# The Boost web site provides free peer-reviewed portable
+# C++ source libraries. The emphasis is on libraries which
+# work well with the C++ Standard Library. The libraries are
+# intended to be widely useful, and are in regular use by
+# thousands of programmers across a broad spectrum of applications.
+DESCRIPTION = "Free peer-reviewed portable C++ source libraries"
+HOMEPAGE = "http://www.boost.org/"
+MAINTAINER = "John Bowler <jbowler@acm.org>"
+SECTION = "libs"
+DEPENDS = "boost-jam-native zlib"
+PRIORITY = "optional"
+LICENSE = "Boost Software License"
+PR = "r0"
+
+# need debian package naming for the libs
+inherit debian
+
+BOOST_VER = "${@"_".join(bb.data.getVar("PV",d,1).split("."))}"
+BOOST_MAJ = "${@"_".join(bb.data.getVar("PV",d,1).split(".")[0:2])}"
+BOOST_P = "boost_${BOOST_VER}"
+SRC_URI = "${SOURCEFORGE_MIRROR}/boost/${BOOST_P}.tar.bz2"
+#SRC_URI += "file://unit_test_log10f.patch;patch=1"
+SRC_URI += "file://linux-uclibc.patch;patch=1"
+
+S = "${WORKDIR}/${BOOST_P}"
+
+# Make a package for each library, plus -dev and -python
+PACKAGES =
+
+PACKAGES += "boost-date-time"
+FILES_boost-date-time = "${libdir}/libboost_date_time.so.${PV}"
+
+PACKAGES += "boost-filesystem"
+FILES_boost-filesystem = "${libdir}/libboost_filesystem.so.${PV}"
+
+PACKAGES += "boost-prg-exec-monitor"
+FILES_boost-prg-exec-monitor = "${libdir}/libboost_prg_exec_monitor.so.${PV}"
+
+PACKAGES += "boost-program-options"
+FILES_boost-program-options = "${libdir}/libboost_program_options.so.${PV}"
+
+PACKAGES += "boost-regex"
+FILES_boost-regex = "${libdir}/libboost_regex.so.${PV}"
+
+PACKAGES += "boost-signals"
+FILES_boost-signals = "${libdir}/libboost_signals.so.${PV}"
+
+PACKAGES += "boost-test-exec-monitor"
+FILES_boost-test-exec-monitor = "${libdir}/libboost_test_exec_monitor.so.${PV}"
+
+PACKAGES += "boost-thread-mt"
+FILES_boost-thread-mt = "${libdir}/libboost_thread-mt.so.${PV}"
+
+PACKAGES += "boost-unit-test-framework"
+FILES_boost-unit-test-framework = "${libdir}/libboost_unit_test_framework.so.${PV}"
+
+PACKAGES += "boost-iostreams"
+FILES_boost-iostreams = "${libdir}/libboost_iostreams.so.${PV}"
+
+PACKAGES += "boost-serialization"
+FILES_boost-serialization = "${libdir}/libboost_serialization.so.${PV}"
+
+PACKAGES += "boost-wserialization"
+FILES_boost-wserialization = "${libdir}/libboost_wserialization.so.${PV}"
+
+# Python - remove this and set:
+#PYTHON_ROOT = "/dev/null"
+# to remove the python build
+DEPENDS += "python"
+PYTHON_ROOT = "${STAGING_DIR}/${HOST_SYS}"
+PYTHON_VERSION = "2.4"
+
+PACKAGES += "boost-python"
+FILES_boost-python = "${libdir}/libboost_python.so.${PV}"
+
+# -dev last to pick up the remaining stuff
+PACKAGES += "${PN}-dev"
+FILES_${PN}-dev = "${includedir} ${libdir}/libboost_*.so ${libdir}/libboost_*.a"
+
+# Oh yippee, a new build system, it's sooo cooool I could eat my own
+# foot.  inlining=on lets the compiler choose, I think.  At least this
+# stuff is documented...
+# NOTE: if you leave <debug-symbols>on then in a debug build the build sys
+# objcopy will be invoked, and that won't work.  Building debug apparently
+# requires hacking gcc-tools.jam
+#
+# Sometimes I wake up screaming.  Famous figures are gathered in the nightmare,
+# Steve Bourne, Larry Wall, the whole of the ANSI C committee.  They're just
+# standing there, waiting, but the truely terrifying thing is what they carry
+# in their hands.  At first sight each seems to bear the same thing, but it is
+# not so for the forms in their grasp are ever so slightly different one from
+# the other.  Each is twisted in some grotesque way from the other to make each
+# an unspeakable perversion impossible to perceive without the onset of madness.
+# True insanity awaits anyone who perceives all of these horrors together.
+#
+# Quotation marks, there might be an easier way to do this, but I can't find
+# it.  The problem is that the user.hpp configuration file must receive a
+# pre-processor macro defined as the appropriate string - complete with "'s
+# around it.  (<> is a possibility here but the danger to that is that the
+# failure case interprets the < and > as shell redirections, creating 
+# random files in the source tree.)
+#
+#bjam: '-DBOOST_PLATFORM_CONFIG=\"config\"'
+#do_compile: '-sGCC=... '"'-DBOOST_PLATFORM_CONFIG=\"config\"'"
+SQD = '"'
+EQD = '\"'
+#boost.bb:   "...  '-sGCC=... '${SQD}'-DBOOST_PLATFORM_CONFIG=${EQD}config${EQD}'${SQD} ..."
+BJAM_CONF = "${SQD}'-DBOOST_PLATFORM_CONFIG=${EQD}boost/config/platform/${TARGET_OS}.hpp${EQD}'${SQD}"
+
+# bzip2 and zip are disabled because... they're broken - the compilation simply
+# isn't working with bjam.  I guess they will fix it, but who needs it?  This
+# only affects the (new in 33) iostream library.
+BJAM_TOOLS   = "-sTOOLS=gcc \
+		'-sGCC=${CC} '${BJAM_CONF} \
+		'-sGXX=${CXX} '${BJAM_CONF} \
+		'-sGCC_INCLUDE_DIRECTORY=${STAGING_INCDIR}' \
+		'-sGCC_STDLIB_DIRECTORY=${STAGING_LIBDIR}' \
+		'-sNO_BZIP2=1' \
+		'-sNO_ZLIB=1' \
+		'-sBUILD=release <optimization>space <inlining>on <debug-symbols>off' \
+		'-sPYTHON_VERSION=${PYTHON_VERSION}' \
+		'--layout=system' \
+		"
+
+BJAM_OPTS    = '${BJAM_TOOLS} \
+		--builddir=${S}/${TARGET_SYS} \
+		--with-python-root=${PYTHON_ROOT} \
+		${BJAM_EXTRA}'
+
+
+do_compile() {
+	set -ex
+	bjam ${BJAM_OPTS} --prefix=${prefix} \
+		--exec-prefix=${exec_prefix} \
+		--libdir=${libdir} \
+		--includedir=${includedir}
+}
+
+do_stage() {
+	set -ex
+	bjam ${BJAM_OPTS} \
+		--libdir=${STAGING_LIBDIR} \
+		--includedir=${STAGING_INCDIR} \
+		install
+}
+
+do_install() {
+	set -ex
+	bjam ${BJAM_OPTS} \
+		--libdir=${D}${libdir} \
+		--includedir=${D}${includedir} \
+		install
+}
-- 
cgit v1.2.3