summaryrefslogtreecommitdiff
path: root/packages/boost/boost-jam-native_3.1.11.bb
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2005-11-30 16:49:19 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-30 16:49:19 +0000
commit277616420978b7c17f2e50d906962802ef79449a (patch)
tree54cb087a727912541173a5b396a2aae6c2b4bc10 /packages/boost/boost-jam-native_3.1.11.bb
parent418712a6150eff75c557860538f605b2856f18c0 (diff)
parentd57e04331835411316c9598e02ea7be22c879fc4 (diff)
merge of affb16dd1c262c6f56c38e1ed230478f0aaa91d7
and ebcf7913b985f1954e5315bca0dfc1c50bb2c940
Diffstat (limited to 'packages/boost/boost-jam-native_3.1.11.bb')
-rw-r--r--packages/boost/boost-jam-native_3.1.11.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/boost/boost-jam-native_3.1.11.bb b/packages/boost/boost-jam-native_3.1.11.bb
new file mode 100644
index 0000000000..cf9f2317c8
--- /dev/null
+++ b/packages/boost/boost-jam-native_3.1.11.bb
@@ -0,0 +1,31 @@
+# The Boost web site provides free peer-reviewed portable
+# C++ source libraries. The emphasis is on libraries which
+# work well with the C++ Standard Library. The libraries are
+# intended to be widely useful, and are in regular use by
+# thousands of programmers across a broad spectrum of applications.
+DESCRIPTION = "Make system for boost (native)"
+HOMEPAGE = "http://www.boost.org/"
+MAINTAINER = "John Bowler <jbowler@acm.org>"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "Boost Software License"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/boost/boost-jam-${PV}.tgz"
+S = "${WORKDIR}/boost-jam-${PV}"
+
+inherit native
+
+do_compile() {
+ set -ex
+ rm -rf bin.*
+ ./build.sh gcc
+}
+
+# This is too terrible - the build script doesn't give any good
+# way I can see to find out where the binaries are placed, so
+# rely on only one bin.foo directory being created.
+do_stage() {
+ set -ex
+ install -c -m 755 bin.*/bjam ${STAGING_BINDIR}/
+}