summaryrefslogtreecommitdiff
path: root/packages/boost-asio/boost-asio_0.3.7.bb
diff options
context:
space:
mode:
authorMatt Reimer <mattjreimer@gmail.com>2006-11-06 18:29:44 +0000
committerMatt Reimer <mattjreimer@gmail.com>2006-11-06 18:29:44 +0000
commit2b622239c20657486f9e84842fd392f0a03c4598 (patch)
tree6b0f2058023f53c03ef7a0419eb06af11e8ba47f /packages/boost-asio/boost-asio_0.3.7.bb
parent5f7acfb7fa919640d4b9e3a997ff4ddfc5a39569 (diff)
parente37ddf6842faf9b3421fa4ab688944a20f0bba94 (diff)
merge of '41daabd524e84d8b355abb1ef7c1d06479c25b7d'
and '749aa1340946e929e3de2422cb6c275ee1ae34ba'
Diffstat (limited to 'packages/boost-asio/boost-asio_0.3.7.bb')
-rw-r--r--packages/boost-asio/boost-asio_0.3.7.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/packages/boost-asio/boost-asio_0.3.7.bb b/packages/boost-asio/boost-asio_0.3.7.bb
new file mode 100644
index 0000000000..07888044f2
--- /dev/null
+++ b/packages/boost-asio/boost-asio_0.3.7.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "Asio 0.3.7 for work with boost, should be moved into boost package once integrated into the boost distribution."
+HOMEPAGE = "http://asio.sf.net/"
+MAINTAINER = "Martin Dietze <dietze@4g-systems.com>"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "Boost Software License"
+PR = "r1"
+
+inherit debian
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/asio/boost_asio_0_3_7.tar.bz2"
+
+# mtx-[12] use 2.4 kernels but the kernel-libc-headers are from kernel 2.6,
+# thus the automatic epoll detection does not work in epoll_reactor_fwd.hpp.
+SRC_URI_append_mtx-1 = " file://disable-epoll.patch;patch=1"
+SRC_URI_append_mtx-2 = " file://disable-epoll.patch;patch=1"
+
+S = "${WORKDIR}/boost_asio_0_3_7"
+
+do_configure() {
+}
+
+do_compile() {
+}
+
+do_install() {
+ cd ${S}
+ install -d ${D}/usr/include
+ cp -dpR boost ${D}/usr/include
+}
+
+do_stage() {
+ cd ${S}
+ install -d -m 775 ${STAGING_INCDIR}
+ cp -dpR boost ${STAGING_INCDIR}
+}
+
+PACKAGES = "${PN}-dev"
+FILES_${PN}-dev = "/usr/include"