summaryrefslogtreecommitdiff
path: root/packages/bluez/files/base.patch
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-09-02 12:42:09 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-02 12:42:09 +0000
commit8998ef3fe7b3bc3a45b627993d905a2965784f36 (patch)
tree5d4cce033398cf9db517c8ffabf11e1dc1f86174 /packages/bluez/files/base.patch
parent23430ca54377133de1107c3cec6d4d063388cc03 (diff)
bluez: update and put related .bb files into one directory
- bluez-libs, bluez-utils, and bluez-hcidump are pretty tied, so I think it makes sense to put them into the same directory - update bluez-libs to 2.20 - update bluez-hcidump to 1.25 - enable default-manfid patch
Diffstat (limited to 'packages/bluez/files/base.patch')
-rw-r--r--packages/bluez/files/base.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/bluez/files/base.patch b/packages/bluez/files/base.patch
new file mode 100644
index 0000000000..337c9aa73e
--- /dev/null
+++ b/packages/bluez/files/base.patch
@@ -0,0 +1,33 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- bluez-utils-2.17/pcmcia/bluetooth~base.patch
++++ bluez-utils-2.17/pcmcia/bluetooth
+@@ -15,9 +15,16 @@
+
+ if [ -r ./shared ]; then . ./shared ; else . /etc/pcmcia/shared ; fi
+
++# Give the port some time to complete initialization
++sleep 5
++
+ # Get device attributes
+ get_info $DEVICE
+
++test "$DEVICE" = "ttyS7" && DEVICE="/dev/tts/7"
++test -z "$MANFID" && MANFID="bcsp"
++test "$MANFID" = "0000,0000" && MANFID="bcsp"
++
+ #
+ # Serial devices
+ #
+@@ -25,7 +32,7 @@
+ IRQ=`setserial /dev/$DEVICE | sed -e 's/.*IRQ: //'`
+ setserial /dev/$DEVICE irq 0 ; setserial /dev/$DEVICE irq $IRQ
+
+- /usr/sbin/hciattach $DEVICE $MANFID
++ /sbin/hciattach $DEVICE $MANFID
+ }
+ stop_serial() {
+ do_fuser -k -HUP /dev/$DEVICE > /dev/null