summaryrefslogtreecommitdiff
path: root/packages/bluez-libs/bluez-libs_2.17.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-07-01 16:26:26 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-01 16:26:26 +0000
commit29ab43535c95595889b29f1956ca2034cbc6d2d2 (patch)
tree705210fc788b9700e28de562b231bca3e9fdf137 /packages/bluez-libs/bluez-libs_2.17.bb
parentdcd2ef29308637847626c5f2e9b3ba4cb37836e2 (diff)
Bluez-Update:
- update bluez-libs to 2.17 - update bluez-utils to 2.17 - fix base.patch against /etc/pcmcia/bluetooth to actually do something
Diffstat (limited to 'packages/bluez-libs/bluez-libs_2.17.bb')
-rw-r--r--packages/bluez-libs/bluez-libs_2.17.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/bluez-libs/bluez-libs_2.17.bb b/packages/bluez-libs/bluez-libs_2.17.bb
new file mode 100644
index 0000000000..7a5df4ebe4
--- /dev/null
+++ b/packages/bluez-libs/bluez-libs_2.17.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Linux Bluetooth Stack Userland Libaries."
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://bluez.sourceforge.net/download/bluez-libs-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+HEADERS = "bluetooth.h bnep.h cmtp.h hci.h hci_lib.h hci_uart.h hci_vhci.h hidp.h l2cap.h rfcomm.h sco.h sdp.h sdp_lib.h"
+
+do_stage() {
+ oe_libinstall -a -so -C src libbluetooth ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/bluetooth/
+ for f in ${HEADERS}
+ do
+ install -m 0644 include/$f ${STAGING_INCDIR}/bluetooth/$f
+ done
+}