summaryrefslogtreecommitdiff
path: root/packages/bind/bind_9.3.1.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-07-11 17:27:18 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-11 17:27:18 +0000
commit6c15bff9b38d0fd2e6d13970a1ee5ba335a7948c (patch)
treed54b761e2871163bc40f2601d74d02f7215d222c /packages/bind/bind_9.3.1.bb
parenta759b97c2875178ed1217673a85cc7c45f3dc590 (diff)
parenteb9cfb0ce0666445f4666daff6e67bdad9fd06fa (diff)
merge of 2022049443b7792bb0aa83a3718b39fa33c7a995
and 9d0d3641c8a092e15958fde6df3c0a92fc97a122
Diffstat (limited to 'packages/bind/bind_9.3.1.bb')
-rw-r--r--packages/bind/bind_9.3.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/bind/bind_9.3.1.bb b/packages/bind/bind_9.3.1.bb
new file mode 100644
index 0000000000..1853d392b1
--- /dev/null
+++ b/packages/bind/bind_9.3.1.bb
@@ -0,0 +1,28 @@
+DEPENDS = "openssl"
+RPEDENDS = ""
+DESCRIPTION = "ISC Internet Domain Name Server"
+MAINTAINER = "NSLU2 Linux <nslu2-linux@yahoogroups.com>"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.isc.org/isc/bind9/9.3.1/bind-9.3.1.tar.gz \
+ file://lib_dns_Makefile.in.patch;patch=1 \
+ file://configure.in.patch;patch=1 \
+ file://conf.patch;patch=1 \
+ "
+
+EXTRA_OECONF = " --enable-ipv6=no --with-randomdev=/dev/random --disable-threads --sysconfdir=/etc/bind --localstatedir=/var --prefix=/usr"
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "bind"
+INITSCRIPT_PARAMS = "defaults"
+
+
+do_install_append() {
+ rm "${D}/usr/bin/nslookup"
+ install -d "${D}/etc/bind"
+ install -d "${D}/etc/init.d"
+ install -m 644 ${S}/conf/* "${D}/etc/bind"
+ install -m 755 "${S}/init.d" "${D}/etc/init.d/bind"
+}
+
+CONFFILES_${PN} = "${sysconfdir}/bind/named.conf ${sysconfdir}/bind/named.conf.local ${sysconfdir}/bind/named.conf.options ${sysconfdir}/bind/db.0 ${sysconfdir}/bind/db.127 ${sysconfdir}/bind/db.empty ${sysconfdir}/bind/db.local ${sysconfdir}/bind/db.root"