summaryrefslogtreecommitdiff
path: root/packages/aufs
diff options
context:
space:
mode:
authorBernhard Guillon <Bernhard.Guillon@opensimpad.org>2009-02-11 14:57:39 +0100
committerBernhard Guillon <Bernhard.Guillon@opensimpad.org>2009-02-11 14:57:39 +0100
commit5082491d1df9f027c5409750f78992a6d877b990 (patch)
treefc1dcba104440fc7a15b13f3c17f9f0a887c793f /packages/aufs
parent1abbf0b0f7d8e04b5293bf23ae89028e06bcb260 (diff)
aufs: fix cross compiling, delete old patch and bump PR
Diffstat (limited to 'packages/aufs')
-rw-r--r--packages/aufs/aufs/aufs_create_no_manpage.patch34
-rw-r--r--packages/aufs/aufs_cvs.bb18
2 files changed, 11 insertions, 41 deletions
diff --git a/packages/aufs/aufs/aufs_create_no_manpage.patch b/packages/aufs/aufs/aufs_create_no_manpage.patch
deleted file mode 100644
index ec7c0c1138..0000000000
--- a/packages/aufs/aufs/aufs_create_no_manpage.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-OE-only:
-comment: Not building the manpage is just a hack.
-
-diff -Nur aufs.vanilla/util/Makefile aufs/util/Makefile
---- aufs.vanilla/util/Makefile 2008-08-23 13:00:37.000000000 +0200
-+++ aufs/util/Makefile 2008-08-23 15:40:26.000000000 +0200
-@@ -1,25 +1,10 @@
-
- # $Id: Makefile,v 1.10 2008/05/26 04:02:40 sfjro Exp $
-
--all: aufs.5 aulchown
-+all: aulchown
- test -x ./mount.aufs || chmod a+x ./mount.aufs
-
--aufs.5: aufs.in.5 ./c2tmac
-- ${RM} $@
-- ./c2tmac > $@
-- awk '{ \
-- gsub(/\140[^\047]*\047/, "\\[oq]&\\[cq]"); \
-- gsub(/\\\[oq\]\140/, "\\[oq]"); \
-- gsub(/\047\\\[cq\]/, "\\[cq]"); \
-- gsub(/\047/, "\\[aq]"); \
-- print; \
-- }' aufs.in.5 >> $@
-- chmod a-w $@
--
- CFLAGS += -O2 -Wall ${EXTRA_CFLAGS} ${ccflags-y}
-
--.INTERMEDIATE: c2tmac.o c2tmac
--c2tmac.o: c2tmac.c ../include/linux/aufs_type.h
--
- clean:
-- ${RM} c2tmac aulchown aufs.5 *~ .*~
-+ ${RM} aulchown *~ .*~
diff --git a/packages/aufs/aufs_cvs.bb b/packages/aufs/aufs_cvs.bb
index cf98e08fc9..815a24fda4 100644
--- a/packages/aufs/aufs_cvs.bb
+++ b/packages/aufs/aufs_cvs.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Aufs is a stackable unification filesystem such as Unionfs, which
HOMEPAGE = "http://aufs.sourceforge.net/"
LICENSE = "GPL"
PV = "cvs${SRCDATE}"
-PR = "r2"
+PR = "r3"
RSUGGESTS_${PN} = "${PN}-tools"
@@ -10,12 +10,6 @@ inherit module
S = "${WORKDIR}/aufs"
-# We do not create the manpage for aufs because we do not install it anyway.
-# If you want to have the manpage created you will need to add host cc to
-# the makefile else it will fail to crosscompile.
-# See http://svn.exactcode.de/t2/trunk/package/filesystem/aufs/compile.patch.cross
-# as an example how this could be done.
-
SRC_URI = "cvs://anonymous@aufs.cvs.sourceforge.net/cvsroot/aufs;module=aufs;date=${SRCDATE}"
EXTRA_OEMAKE = "KDIR=${STAGING_KERNEL_DIR} -f local.mk"
@@ -39,6 +33,16 @@ do_configure() {
fi
}
+do_compile_prepend() {
+#compile binaries for host
+ cd ${S}/util
+ BRANCH_MAX=$(fgrep CONFIG_AUFS_BRANCH_MAX ../local.mk | grep y | cut -d " " -f 2)
+ ${BUILD_CC} -D ${BRANCH_MAX} c2tmac.c ../include/linux/aufs_type.h -o c2tmac
+ ${BUILD_CC} -D ${BRANCH_MAX} c2sh.c ../include/linux/aufs_type.h -o c2sh
+ cd ${S}
+}
+
+
do_install() {
install -d ${D}/${sbindir}
install -m 0500 mount.aufs umount.aufs auplink aulchown ${D}/${sbindir}