summaryrefslogtreecommitdiff
path: root/packages/at76c503a
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-02-17 08:19:00 +0000
committerKoen Kooi <koen@openembedded.org>2008-02-17 08:19:00 +0000
commit0395d7bcfd686b1e3761ae3dcb0d30f116a1d11a (patch)
tree7ca5f482cc38a2398d71825591c4f30e65031083 /packages/at76c503a
parentcc18c223877b9f7a02cf77ee3b2391a4315aec04 (diff)
at76c503a: add 0.17 release of at76_usb modules
* this works with 2.6.21-hh for the h5000 machine * this driver also needs a firmware package, that will follow later
Diffstat (limited to 'packages/at76c503a')
-rw-r--r--packages/at76c503a/at76c503a-modules_0.17.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/packages/at76c503a/at76c503a-modules_0.17.bb b/packages/at76c503a/at76c503a-modules_0.17.bb
new file mode 100644
index 0000000000..affffa39ef
--- /dev/null
+++ b/packages/at76c503a/at76c503a-modules_0.17.bb
@@ -0,0 +1,19 @@
+SECTION = "base"
+LICENSE = "GPL"
+
+SRCDATE = "20080116"
+
+SRC_URI = "http://download.berlios.de/at76c503a/at76_usb-0.17.tar.gz"
+S = "${WORKDIR}/at76_usb-${PV}/"
+
+inherit module
+
+MODULES = "at76c503 at76_usbdfu at76c503-i3861 at76c503-rfmd at76c503-rfmd-acc \
+ at76c505-rfmd at76c503-i3863 at76c505-rfmd2958"
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/
+ for i in *${KERNEL_OBJECT_SUFFIX}; do
+ install -m 0644 $i ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/
+ done
+}