summaryrefslogtreecommitdiff
path: root/packages/altboot
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2006-04-03 09:18:43 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-03 09:18:43 +0000
commite16288a8cfa94af17760097a3f04ff42be47ba76 (patch)
treeb2b7f980a7f6369960df6f4770dbcfa8629b3f66 /packages/altboot
parent3d7661e995ea25e3d6909a0c711817495f54ac32 (diff)
altboot: Remove spitz's postinst and postrm for kernel 2.4
Diffstat (limited to 'packages/altboot')
-rw-r--r--packages/altboot/altboot_0.0.0.bb71
1 files changed, 1 insertions, 70 deletions
diff --git a/packages/altboot/altboot_0.0.0.bb b/packages/altboot/altboot_0.0.0.bb
index 2efea00238..5981b41231 100644
--- a/packages/altboot/altboot_0.0.0.bb
+++ b/packages/altboot/altboot_0.0.0.bb
@@ -6,7 +6,7 @@ MAINTAINER = "Matthias 'CoreDump' Hentges <oe@hentges.net>"
LICENSE = "GPL"
IGNORE_STRIP_ERRORS = "1"
-PR = "r31"
+PR = "r32"
SRC_URI = "file://altboot-menu \
@@ -44,75 +44,6 @@ pkg_postinst() {
update-alternatives --install /sbin/init init /sbin/init.altboot 55
}
-pkg_postinst_spitz() {
- # Note: Spitz support is a royal pain in the ass.
- # Since Spitz pivot_roots by default, there is no real way
- # a user can install an altboot.ipk into the flash FS.
- # So we need to do that manually (*SIGH*)
-
- # the 2.6 kernel for spitz boots from HDD, no need to copy to flash
- if cat /proc/version | awk '{print $3}' | grep -q '^2.6'; then
- update-alternatives --install /sbin/init init /sbin/init.altboot 55
- # no need to copy to flash if we're installing to flash already
- elif mount | grep ' / ' | grep -q mtdblock; then
- update-alternatives --install /sbin/init init /sbin/init.altboot 55
- else
- # /l/m only exists on the HDD on spitz
- if test -d /lib/modules
- then
- if [ -e /media/realroot/sbin/init ]; then
- ROOT_MOUNT_POINT="/media/realroot"
- elif [ -e /media/ROM/sbin/init ]; then
- ROOT_MOUNT_POINT="/media/ROM"
- fi
- if [ ! "$ROOT_MOUNT_POINT" = "" ]; then
- ROOT_MOUNT_DEVICE=`cat /proc/mounts | grep $ROOT_MOUNT_POINT | grep jffs2 | cut -d " " -f 1`
- if [ ! "$ROOT_MOUNT_DEVICE" = "" ]; then
- mount -oremount,rw $ROOT_MOUNT_DEVICE $ROOT_MOUNT_POINT
- cp -R /etc/altboot* $ROOT_MOUNT_POINT/etc
- cp /sbin/init.altboot $ROOT_MOUNT_POINT/sbin
- if [ -f $ROOT_MOUNT_POINT/sbin/init ]; then
- mv $ROOT_MOUNT_POINT/sbin/init $ROOT_MOUNT_POINT/sbin/init.orig
- fi
- ln -s /sbin/init.altboot $ROOT_MOUNT_POINT/sbin/init
- fi
- fi
- fi
- fi
-}
-
pkg_postrm() {
update-alternatives --remove init /sbin/init.altboot
}
-
-pkg_postrm_spitz() {
- # the 2.6 kernel for spitz boots from HDD, no need to remove from flash
- if cat /proc/version | awk '{print $3}' | grep -q '^2.6'; then
- update-alternatives --remove init /sbin/init.altboot
- # no need to copy to flash if we're removing from flash already
- elif mount | grep ' / ' | grep -q mtdblock; then
- update-alternatives --remove init /sbin/init.altboot
- else
- if test -d /lib/modules
- then
- if [ -e /media/realroot/sbin/init ]; then
- ROOT_MOUNT_POINT="/media/realroot"
- elif [ -e /media/ROM/sbin/init ]; then
- ROOT_MOUNT_POINT="/media/ROM"
- fi
- if [ ! "$ROOT_MOUNT_POINT" = "" ]; then
- ROOT_MOUNT_DEVICE=`cat /proc/mounts | grep $ROOT_MOUNT_POINT | grep jffs2 | cut -d " " -f 1`
- if [ ! "$ROOT_MOUNT_DEVICE" = "" ]; then
- mount -oremount,rw $ROOT_MOUNT_DEVICE $ROOT_MOUNT_POINT
- if [ -f $ROOT_MOUNT_POINT/sbin/init.orig ]; then
- rm $ROOT_MOUNT_POINT/sbin/init
- rm $ROOT_MOUNT_POINT/sbin/init.altboot
- mv $ROOT_MOUNT_POINT/sbin/init.orig $ROOT_MOUNT_POINT/sbin/init
- else
- echo "$ROOT_MOUNT_POINT/sbin/init.orig not found, not uninstalling altboot!"
- fi
- fi
- fi
- fi
- fi
-}