summaryrefslogtreecommitdiff
path: root/packages/alsa
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2005-08-19 23:25:33 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-19 23:25:33 +0000
commita085235edaa93ff6bbca5eb0c48845136450a90a (patch)
tree5b5635756b82688f04aa2624e58a4e9a0289b9c7 /packages/alsa
parent69ee91776ad264c273395ff1cfe40c1c655ccbec (diff)
alsa-driver: first try at making things actually work.
- remove commented out code - inherit autotools and module classes - use KERNEL_VERSION as defined by module.bbclass - FILES is defined correctly by module.bbclass as well - make do_configure() use oe_runconf (didn't work at all before this change) - Pigi removed the h5400 patch. need to investigate whether this was by intention
Diffstat (limited to 'packages/alsa')
-rw-r--r--packages/alsa/alsa-driver_0.9.6-hh4c.bb43
1 files changed, 14 insertions, 29 deletions
diff --git a/packages/alsa/alsa-driver_0.9.6-hh4c.bb b/packages/alsa/alsa-driver_0.9.6-hh4c.bb
index b045af116a..a909c0211c 100644
--- a/packages/alsa/alsa-driver_0.9.6-hh4c.bb
+++ b/packages/alsa/alsa-driver_0.9.6-hh4c.bb
@@ -1,34 +1,25 @@
DESCRIPTION = "Alsa Drivers"
MAINTAINER = "Pigi"
-SECTION = "console/utils"
+SECTION = "base"
LICENSE = "GPL"
-#DEPENDS = "alsa-lib"
-PR = "r1"
-
-
+PR = "r2"
SRC_URI = "ftp://ftp.handhelds.org/packages/alsa-driver/alsa-driver-${PV}.tar.gz \
file://sound.p.patch;patch=1 \
file://sa11xx.patch;patch=1 \
- file://adriver.h.patch;patch=1 "
+ file://adriver.h.patch;patch=1"
-#inherit autotools
-#inherit module
+inherit autotools module
-#EXTRA_OECONF = " --with-isapnp=no "
-EXTRA_OECONF=" --with-sequencer=no --with-isapnp=no --with-oss=yes --with-cards=${cards} --with-kernel=${STAGING_KERNEL_DIR} --with-kernel-version=${KERNEL_VERSION} --host=arm-linux"
-#EXTRA_OECONF = " /ext/ambient/tmp/work/handhelds-sa-2.4.19-rmk6-pxa1-hh37.4-r5/kernel/ "
+EXTRA_OECONF=" --with-sequencer=no \
+ --with-isapnp=no \
+ --with-oss=yes \
+ --with-kernel=${STAGING_KERNEL_DIR} \
+ --with-kernel-version=${KERNEL_VERSION}"
do_configure() {
-VERS=`grep "^VERSION =" ${STAGING_KERNEL_DIR}/Makefile | awk '{print $3}'`
-PATLEV=`grep "^PATCHLEVEL =" ${STAGING_KERNEL_DIR}/Makefile | awk '{print $3}'`
-SBLEV=`grep "^SUBLEVEL =" ${STAGING_KERNEL_DIR}/Makefile | awk '{print $3}'`
-EXVER=`grep "^EXTRAVERSION =" ${STAGING_KERNEL_DIR}/Makefile | awk '{print $3}'`
-
-KERNEL_VERSION=$VERS.$PATLEV.$SBLEV$EXVER
-
cards=
if egrep "CONFIG_SA1100_H3[168]00=y" "${STAGING_KERNEL_DIR}/.config" ; then
cards="$cards,sa11xx-uda1341"
@@ -40,13 +31,10 @@ if grep "CONFIG_ARCH_H3900=y" "${STAGING_KERNEL_DIR}/.config" ; then
fi
cards="$cards,bluez-sco,pdaudiocf"
- configure ${EXTRA_OECONF}
- #./config.ipaq ${STAGING_KERNEL_DIR}
-
+ oe_runconf --with-cards=${cards}
}
-
do_install() {
if egrep "CONFIG_SA1100_H3[168]00=y" "${STAGING_KERNEL_DIR}/.config" ; then
@@ -65,13 +53,10 @@ extra_modules="snd-gus-synth.o snd-emu8000-synth.o snd-emux-synth.o \
do rm -f ${D}/lib/modules/*/misc/$i;
done
- if [ -d ${D}/${sysconfdir}/modutils/ ] ; then
- rm -r ${D}/${sysconfdir}/modutils/ ;
+ if [ -d ${D}${sysconfdir}/modutils/ ] ; then
+ rm -r ${D}${sysconfdir}/modutils/ ;
fi
- mkdir ${D}/${sysconfdir}/modutils/
- cp familiar/alsa-modules-${familiar_arch} ${D}/${sysconfdir}/modutils/
+ mkdir -p ${D}${sysconfdir}/modutils/
+ cp familiar/alsa-modules-${familiar_arch} ${D}${sysconfdir}/modutils/
}
-#FILES_alsa-driver = "/lib/modules/${KERNEL_VERSION}/misc/snd* /${sysconfdir}/init.d/ /${sysconfdir}"
-FILES_${PN} = "/lib/modules/*/misc/snd* ${sysconfdir}/modutils/* "
-