summaryrefslogtreecommitdiff
path: root/packages/alsa
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-09-21 10:10:32 +0000
committerKoen Kooi <koen@openembedded.org>2007-09-21 10:10:32 +0000
commit91956c1fa5dff3c9bebe9e8fa33742aa0bdcb332 (patch)
treed3160acbb1ec14c4daf57e55a374940916862b34 /packages/alsa
parentd2a11d6e6baf43e83a769b58d04be160bf3987ca (diff)
alsa-state: add config for a780
Diffstat (limited to 'packages/alsa')
-rw-r--r--packages/alsa/alsa-state.bb2
-rw-r--r--packages/alsa/alsa-state/a780/.mtn2git_empty0
-rw-r--r--packages/alsa/alsa-state/a780/asound.state80
3 files changed, 81 insertions, 1 deletions
diff --git a/packages/alsa/alsa-state.bb b/packages/alsa/alsa-state.bb
index e2a92dcfc8..0544dd4bd5 100644
--- a/packages/alsa/alsa-state.bb
+++ b/packages/alsa/alsa-state.bb
@@ -8,7 +8,7 @@ DESCRIPTION = "Default ALSA configuration"
LICENSE = "GPL"
RRECOMMENDS_alsa-state = "alsa-states"
PV = "0.1.0"
-PR = "r1"
+PR = "r2"
SRC_URI = " \
file://asoundrc \
diff --git a/packages/alsa/alsa-state/a780/.mtn2git_empty b/packages/alsa/alsa-state/a780/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/alsa/alsa-state/a780/.mtn2git_empty
diff --git a/packages/alsa/alsa-state/a780/asound.state b/packages/alsa/alsa-state/a780/asound.state
new file mode 100644
index 0000000000..eafd409857
--- /dev/null
+++ b/packages/alsa/alsa-state/a780/asound.state
@@ -0,0 +1,80 @@
+state.EZX {
+ control.1 {
+ comment.access 'read write'
+ comment.type INTEGER
+ comment.count 1
+ comment.range '0 - 15'
+ iface MIXER
+ name 'Output gain'
+ value 9
+ }
+ control.2 {
+ comment.access 'read write'
+ comment.type INTEGER
+ comment.count 1
+ comment.range '0 - 31'
+ iface MIXER
+ name 'Input gain'
+ value 14
+ }
+ control.3 {
+ comment.access 'read write'
+ comment.type BOOLEAN
+ comment.count 1
+ iface MIXER
+ name 'Input Mixer A3 Switch'
+ value true
+ }
+ control.4 {
+ comment.access 'read write'
+ comment.type BOOLEAN
+ comment.count 1
+ iface MIXER
+ name 'Input Mixer A5 Switch'
+ value true
+ }
+ control.5 {
+ comment.access 'read write'
+ comment.type BOOLEAN
+ comment.count 1
+ iface MIXER
+ name 'Output Mixer A1 Switch'
+ value true
+ }
+ control.6 {
+ comment.access 'read write'
+ comment.type BOOLEAN
+ comment.count 1
+ iface MIXER
+ name 'Output Mixer A2 Switch'
+ value true
+ }
+ control.7 {
+ comment.access 'read write'
+ comment.type BOOLEAN
+ comment.count 1
+ iface MIXER
+ name 'Output Mixer AR Switch'
+ value true
+ }
+ control.8 {
+ comment.access 'read write'
+ comment.type BOOLEAN
+ comment.count 1
+ iface MIXER
+ name 'Output Mixer AL Switch'
+ value true
+ }
+ control.9 {
+ comment.access 'read write'
+ comment.type ENUMERATED
+ comment.count 1
+ comment.item.0 '2ch'
+ comment.item.1 '2->1ch'
+ comment.item.2 '2->1ch -3db'
+ comment.item.3 '2->1ch -6db'
+ iface MIXER
+ name Downmixer
+ value '2ch'
+ }
+}