summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjeff <jhatch@multitech.com>2022-08-24 09:45:34 -0500
committerjeff <jhatch@multitech.com>2022-08-24 09:45:34 -0500
commitded5f2d0de75fe8fcbcd97342c44238ece5d8346 (patch)
treee66557615fcd7263db1ecb14b52a4e762598f27a
parent3dffdad6aecc7e9f933aca82851d3d25bba5226d (diff)
parent7f20d14036eea9ccc2da0ca2c21308fd65b063eb (diff)
downloadmeta-multitech-ded5f2d0de75fe8fcbcd97342c44238ece5d8346.tar.gz
meta-multitech-ded5f2d0de75fe8fcbcd97342c44238ece5d8346.tar.bz2
meta-multitech-ded5f2d0de75fe8fcbcd97342c44238ece5d8346.zip
Merge branch 'vp/mtcpmhs/hv_0.2' into 6
-rwxr-xr-xrecipes-bsp/multitech/mt-dt-overlay/init-mtcpmhs6
-rw-r--r--recipes-bsp/multitech/mt-dt-overlay_1.2.9.bb (renamed from recipes-bsp/multitech/mt-dt-overlay_1.2.8.bb)0
-rwxr-xr-xrecipes-bsp/multitech/mts-io/mts-io.init3
-rw-r--r--recipes-bsp/multitech/mts-io_4.9.9.bb (renamed from recipes-bsp/multitech/mts-io_4.9.8.bb)0
4 files changed, 8 insertions, 1 deletions
diff --git a/recipes-bsp/multitech/mt-dt-overlay/init-mtcpmhs b/recipes-bsp/multitech/mt-dt-overlay/init-mtcpmhs
index defb318..9c3c066 100755
--- a/recipes-bsp/multitech/mt-dt-overlay/init-mtcpmhs
+++ b/recipes-bsp/multitech/mt-dt-overlay/init-mtcpmhs
@@ -6,7 +6,7 @@
sysdir=/sys/devices/platform/mts-io
I2CDIR="/sys/bus/i2c/devices"
-eepromPath="${I2CDIR}/0-0056/eeprom"
+eepromPath="${I2CDIR}/1-0050/eeprom"
DEVTREE="/sys/kernel/config/device-tree/overlays/"
SYSFS="/usr/sbin/mts-io-sysfs"
@@ -63,6 +63,10 @@ install_dtbo_dir() {
# [file1] [file2] [file3]
setdevtree() {
eeprom=$(mts-id-eeprom --in-file "$eepromPath" 2>/dev/null)
+ if (( $? != 0 )); then
+ echo "Failed to read EEPROM from the Base Board"
+ return 1
+ fi
[[ $eeprom =~ [[:space:]]hw-version:[[:space:]]*\"([^\"]+) ]]
hw=${BASH_REMATCH[1]}
mach=${hw/%-*}
diff --git a/recipes-bsp/multitech/mt-dt-overlay_1.2.8.bb b/recipes-bsp/multitech/mt-dt-overlay_1.2.9.bb
index d9b4f7a..d9b4f7a 100644
--- a/recipes-bsp/multitech/mt-dt-overlay_1.2.8.bb
+++ b/recipes-bsp/multitech/mt-dt-overlay_1.2.9.bb
diff --git a/recipes-bsp/multitech/mts-io/mts-io.init b/recipes-bsp/multitech/mts-io/mts-io.init
index f4bc6ed..98f3e4c 100755
--- a/recipes-bsp/multitech/mts-io/mts-io.init
+++ b/recipes-bsp/multitech/mts-io/mts-io.init
@@ -299,6 +299,9 @@ set_links() {
MTCPM-0.1)
ln -sf /dev/ttyACM0 /dev/gps0
;;
+ MTCPM-0.2)
+ ln -sf /dev/ttyS4 /dev/gps0
+ ;;
esac
echo "u-blox" >"$GPSCONFIGTYPE"
return
diff --git a/recipes-bsp/multitech/mts-io_4.9.8.bb b/recipes-bsp/multitech/mts-io_4.9.9.bb
index ee4fcfa..ee4fcfa 100644
--- a/recipes-bsp/multitech/mts-io_4.9.8.bb
+++ b/recipes-bsp/multitech/mts-io_4.9.9.bb