summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjhatch <jhatch@multitech.com>2015-10-13 08:00:35 -0500
committerjhatch <jhatch@multitech.com>2015-10-13 09:45:17 -0500
commitd57cce5f3f6fb108c2c9e26712cf92705eebc476 (patch)
tree7297552f451e3d6b83e7f1a26b473cd62b5956a5
parent1dc0c89c86123ef1c876785e4dc806ac3d6024c8 (diff)
downloadmeta-multitech-d57cce5f3f6fb108c2c9e26712cf92705eebc476.tar.gz
meta-multitech-d57cce5f3f6fb108c2c9e26712cf92705eebc476.tar.bz2
meta-multitech-d57cce5f3f6fb108c2c9e26712cf92705eebc476.zip
Fix logging verbosity when disconnecting from cell modem tty:
From Linux stable kernel 4ad8d53c777d5b48115b8cb9e73391ac434f9e60: USB: option: reduce interrupt-urb logging verbosity commit f0e4cba2534cd88476dff920727c81350130f3c5 upstream. Do not log normal interrupt-urb shutdowns as errors. The option driver has always been logging any nonzero interrupt-urb status as an error, including when the urb is killed during normal operation. Commit 9096f1fbba91 ("USB: usb_wwan: fix potential NULL-deref at resume") moved the interrupt urb submission from port probe and release to open and close, thus potentially increasing the number of these false-positive error messages dramatically. Reported-by: Ed Butler <ressy66@ausics.net> Tested-by: Ed Butler <ressy66@ausics.net> Signed-off-by: Johan Hovold <johan@kernel.org> Signed-off-by: Jiri Slaby <jslaby@suse.cz>
-rw-r--r--recipes-kernel/linux/linux-3.12.27/linux-3.12.27-USB-option-reduce-interrupt-urb-logging-verbosity.patch13
-rw-r--r--recipes-kernel/linux/linux_3.12.27.bb1
2 files changed, 14 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-3.12.27/linux-3.12.27-USB-option-reduce-interrupt-urb-logging-verbosity.patch b/recipes-kernel/linux/linux-3.12.27/linux-3.12.27-USB-option-reduce-interrupt-urb-logging-verbosity.patch
new file mode 100644
index 0000000..b6aaf3a
--- /dev/null
+++ b/recipes-kernel/linux/linux-3.12.27/linux-3.12.27-USB-option-reduce-interrupt-urb-logging-verbosity.patch
@@ -0,0 +1,13 @@
+Index: linux-3.12.27/drivers/usb/serial/option.c
+===================================================================
+--- linux-3.12.27.orig/drivers/usb/serail/option.c 2015-10-12 08:23:22.665755983 -0500
++++ linux-3.12.27/drivers/usb/serial/option.c 2015-10-12 08:26:24.028205802 -0500
+@@ -1927,6 +1927,8 @@ static void option_instat_callback(struct urb *urb)
+ dev_dbg(dev, "%s: type %x req %x\n", __func__,
+ req_pkt->bRequestType, req_pkt->bRequest);
+ }
++ } else if (status == -ENOENT || status == -ESHUTDOWN) {
++ dev_dbg(dev, "%s: urb stopped: %d\n", __func__, status);
+ } else
+ dev_err(dev, "%s: error %d\n", __func__, status);
+
diff --git a/recipes-kernel/linux/linux_3.12.27.bb b/recipes-kernel/linux/linux_3.12.27.bb
index c46b575..1ca2f79 100644
--- a/recipes-kernel/linux/linux_3.12.27.bb
+++ b/recipes-kernel/linux/linux_3.12.27.bb
@@ -24,6 +24,7 @@ COMMON_PATCHES = " \
file://linux-3.12-cdc-acm-ignore-exar-devices.patch \
file://linux-3.12-release-rfcomm-port-fix.patch \
file://linux-3.12-spi-atmel-dma-min.patch \
+ file://linux-3.12.27-USB-option-reduce-interrupt-urb-logging-verbosity.patch \
"
SRC_URI_append_mtcdt = "\