summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerhii Kostiuk <serhii.o.kostiuk@globallogic.com>2022-02-05 08:06:01 +0200
committerSerhii Kostiuk <serhii.o.kostiuk@globallogic.com>2022-02-05 08:06:01 +0200
commitcfcacbc603cae660cee5ed753754cb97b91352c6 (patch)
treea45eb92be0ec0d747a4d18ed5fd365896a1b1c08
parent03efeb514d6845cbc786b3ca2329c2e3b0338743 (diff)
parent374ba433f7573702ab3d58581ce62192a345fc90 (diff)
downloadmeta-multitech-cfcacbc603cae660cee5ed753754cb97b91352c6.tar.gz
meta-multitech-cfcacbc603cae660cee5ed753754cb97b91352c6.tar.bz2
meta-multitech-cfcacbc603cae660cee5ed753754cb97b91352c6.zip
Merge remote-tracking branch 'origin/6' into mpower-dev-nxp
-rwxr-xr-xrecipes-bsp/multitech/mt-dt-overlay/init28
-rw-r--r--recipes-bsp/multitech/mt-dt-overlay_1.1.2.bb2
-rwxr-xr-xrecipes-bsp/multitech/mts-io/mts-io.init4
3 files changed, 18 insertions, 16 deletions
diff --git a/recipes-bsp/multitech/mt-dt-overlay/init b/recipes-bsp/multitech/mt-dt-overlay/init
index c2d9716..00af9f8 100755
--- a/recipes-bsp/multitech/mt-dt-overlay/init
+++ b/recipes-bsp/multitech/mt-dt-overlay/init
@@ -6,7 +6,7 @@
sysdir=/sys/devices/platform/mts-io
i2c=/sys/bus/i2c/devices/
-eepromPath="/sys/devices/platform/i2c-gpio-0/i2c-0/0-0056/eeprom"
+eepromPath="/sys/bus/i2c/devices/0-0056/eeprom"
DEVTREE="/sys/kernel/config/device-tree/overlays/"
SYSFS="/usr/sbin/mts-io-sysfs"
@@ -49,14 +49,17 @@ install_dtbo_dir() {
# [flag]
# [file1] [file2] [file3]
setdevtree() {
- hwlin=$(mts-id-eeprom --in-file "$eepromPath" 2>/dev/null | grep '^hw-version:')
- [[ $hwlin =~ hw-version:[[:space:]]*\"([^\"]+) ]]
+ eeprom=$(mts-id-eeprom --in-file "$eepromPath" 2>/dev/null)
+ [[ $eeprom =~ [[:space:]]hw-version:[[:space:]]*\"([^\"]+) ]]
hw=${BASH_REMATCH[1]}
mach=${hw/%-*}
rev=${hw/#*-/}
echo mach is $mach
echo rev is $rev
- capd="${sysdir}/capability"
+
+ regx='capa-(.*):[[:space:]]*true'
+ capflags=$(echo "$eeprom" | egrep "$regx" | sed -e 's/capa-//g' -e 's/: true//')
+ capflags=" ${capflags} "
# add device tree overlays, if they exist.
[[ -d /lib/dtoverlays ]] || return 1
@@ -83,15 +86,14 @@ setdevtree() {
if [[ -d capability ]] ; then
cd capability
for d in * ; do
- if [[ -f ${capd}/$d ]] ; then
- if (($(cat ${capd}/$d) == 1)) ; then
- echo "This device has capabilithy $d"
- (
- cd $d
- install_dtbo_dir
- )
- fi # Install dtbo files for a capability
- fi # Does a given capability flag exist in the mts-io platform
+ echo "We have found overlay capability directory $d"
+ if [[ ${capflags} =~ [[:space:]]${d}[[:space:]] ]] ; then
+ echo "This device has capabilithy $d so install the overlay"
+ (
+ cd $d
+ install_dtbo_dir
+ )
+ fi # Does a given capability flag exist in the EEPROM
done # Loop over all capabilities for this machine and version overlays
fi # Is there a capability directory to be installed?
)
diff --git a/recipes-bsp/multitech/mt-dt-overlay_1.1.2.bb b/recipes-bsp/multitech/mt-dt-overlay_1.1.2.bb
index 09c8f4a..98fb5e4 100644
--- a/recipes-bsp/multitech/mt-dt-overlay_1.1.2.bb
+++ b/recipes-bsp/multitech/mt-dt-overlay_1.1.2.bb
@@ -24,7 +24,7 @@ COMPATIBLE_MACHINE = "(mtcap|mtrv1|mtcdt)"
dt_dir = "/lib/dtoverlays"
-PR = "r3"
+PR = "r4"
SRC_URI = " \
git://git.multitech.net/mt-dt-overlay.git;protocol=git \
diff --git a/recipes-bsp/multitech/mts-io/mts-io.init b/recipes-bsp/multitech/mts-io/mts-io.init
index b62bcb1..f4bc6ed 100755
--- a/recipes-bsp/multitech/mts-io/mts-io.init
+++ b/recipes-bsp/multitech/mts-io/mts-io.init
@@ -209,11 +209,11 @@ read_card_info() {
lora_hw=$(${SYSFS} show lora/hw-version 2> /dev/null)
if [[ $hw_name == MTCDT3 ]] ; then
- # SYM Link and spidev module is not needed in MTCDT3.
+ # spidev module is not needed in MTCDT3.
return 0
fi
- if [[ ${hw_name} == MTCAP ]] || [[ ${hw_name} == MTCDT ]]; then
+ if [[ ${hw_name} == MTCAP ]] || [[ ${hw_name} == MTCDT ]] || [[ ${hw_name} == MTCDTIP ]]; then
modprobe spidev
elif [[ ${hw_name} == MTCDTIPHP ]]; then
modprobe spidev