summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVyacheslav Pedash <vyacheslav.pedash@globallogic.com>2021-03-11 17:28:59 +0200
committerJohn Klug <john.klug@multitech.com>2021-03-11 12:02:09 -0600
commit9ae801a1a01a670aa0ac920182ac86ba0b9ca6bb (patch)
tree1a3504bfa56522231f07dee1523b792f2b996564
parenteb1ad84177ae65e64cf08159243b91da7f5d5450 (diff)
downloadmeta-multitech-9ae801a1a01a670aa0ac920182ac86ba0b9ca6bb.tar.gz
meta-multitech-9ae801a1a01a670aa0ac920182ac86ba0b9ca6bb.tar.bz2
meta-multitech-9ae801a1a01a670aa0ac920182ac86ba0b9ca6bb.zip
MTX-3899 Fix PR values
The value of WORKDIR variable depends on PR. If PR and consequently WORKDIR changes its value build will fail because values in butbake cache will not correspond to the real ones. KERNEL_MODULE_PACKAGE_SUFFIX is derived from files in kernel staging directory and cosequenlty recives expected value only when kernel shared directory is populated. Therefore, it can not be used in PR. PR values are set to constant strings and to preserve current package names KERNEL_MODULE_PACKAGE_SUFFIX is added to PKGR
-rw-r--r--recipes-bsp/multitech/mtac-eth_1.1.1.bb4
-rw-r--r--recipes-bsp/multitech/mtac-gpiob_1.1.2.bb4
-rw-r--r--recipes-bsp/multitech/mtac-lora_1.1.5.bb4
-rw-r--r--recipes-bsp/multitech/mtac-mfser_1.1.1.bb4
-rw-r--r--recipes-bsp/multitech/mtac-pulse_1.1.1.bb4
-rw-r--r--recipes-bsp/multitech/mtac-xdot_1.1.1.bb4
-rw-r--r--recipes-bsp/multitech/mtac_4.0.7.bb4
-rw-r--r--recipes-bsp/multitech/mts-io.inc3
8 files changed, 23 insertions, 8 deletions
diff --git a/recipes-bsp/multitech/mtac-eth_1.1.1.bb b/recipes-bsp/multitech/mtac-eth_1.1.1.bb
index 4f9d830..b833f75 100644
--- a/recipes-bsp/multitech/mtac-eth_1.1.1.bb
+++ b/recipes-bsp/multitech/mtac-eth_1.1.1.bb
@@ -12,7 +12,9 @@ COMPATIBLE_MACHINE = "(mtcdt|mtcpmhs)"
SRCREV = "${PV}"
-PR = "${INC_PR}.1${KERNEL_MODULE_PACKAGE_SUFFIX}"
+PR = "${INC_PR}.1"
+
+PKGR = "${PR}${KERNEL_MODULE_PACKAGE_SUFFIX}${EXTENDPRAUTO}"
SRC_URI = " \
git://git.multitech.net/mtac-eth.git;protocol=git;branch=master \
diff --git a/recipes-bsp/multitech/mtac-gpiob_1.1.2.bb b/recipes-bsp/multitech/mtac-gpiob_1.1.2.bb
index 3b704d1..701ff07 100644
--- a/recipes-bsp/multitech/mtac-gpiob_1.1.2.bb
+++ b/recipes-bsp/multitech/mtac-gpiob_1.1.2.bb
@@ -14,7 +14,9 @@ SRCREV = "${PV}"
# AUTOREV breaks mLinux source tarballs in Thud
# SRCREV = "${AUTOREV}"
-PR = "${INC_PR}.1${KERNEL_MODULE_PACKAGE_SUFFIX}"
+PR = "${INC_PR}.1"
+
+PKGR = "${PR}${KERNEL_MODULE_PACKAGE_SUFFIX}${EXTENDPRAUTO}"
SRC_URI = " \
git://git.multitech.net/mtac-gpiob.git;protocol=git;branch=master \
diff --git a/recipes-bsp/multitech/mtac-lora_1.1.5.bb b/recipes-bsp/multitech/mtac-lora_1.1.5.bb
index 357da00..fda4f5c 100644
--- a/recipes-bsp/multitech/mtac-lora_1.1.5.bb
+++ b/recipes-bsp/multitech/mtac-lora_1.1.5.bb
@@ -12,7 +12,9 @@ COMPATIBLE_MACHINE = "(mtcdt|mtcpmhs)"
SRCREV = "${PV}"
-PR = "${INC_PR}.1${KERNEL_MODULE_PACKAGE_SUFFIX}"
+PR = "${INC_PR}.1"
+
+PKGR = "${PR}${KERNEL_MODULE_PACKAGE_SUFFIX}${EXTENDPRAUTO}"
SRC_URI = " \
git://git.multitech.net/mtac-lora.git;protocol=git;branch=master \
diff --git a/recipes-bsp/multitech/mtac-mfser_1.1.1.bb b/recipes-bsp/multitech/mtac-mfser_1.1.1.bb
index 21e22a2..213ec1d 100644
--- a/recipes-bsp/multitech/mtac-mfser_1.1.1.bb
+++ b/recipes-bsp/multitech/mtac-mfser_1.1.1.bb
@@ -12,7 +12,9 @@ COMPATIBLE_MACHINE = "(mtcdt|mtcpmhs)"
SRCREV = "${PV}"
-PR = "${INC_PR}.1${KERNEL_MODULE_PACKAGE_SUFFIX}"
+PR = "${INC_PR}.1"
+
+PKGR = "${PR}${KERNEL_MODULE_PACKAGE_SUFFIX}${EXTENDPRAUTO}"
SRC_URI = " \
git://git.multitech.net/mtac-mfser.git;protocol=git;branch=master \
diff --git a/recipes-bsp/multitech/mtac-pulse_1.1.1.bb b/recipes-bsp/multitech/mtac-pulse_1.1.1.bb
index c744b39..1fefdba 100644
--- a/recipes-bsp/multitech/mtac-pulse_1.1.1.bb
+++ b/recipes-bsp/multitech/mtac-pulse_1.1.1.bb
@@ -12,7 +12,9 @@ COMPATIBLE_MACHINE = "(mtcdt|mtcpmhs)"
SRCREV = "${PV}"
-PR = "${INC_PR}.1${KERNEL_MODULE_PACKAGE_SUFFIX}"
+PR = "${INC_PR}.1"
+
+PKGR = "${PR}${KERNEL_MODULE_PACKAGE_SUFFIX}${EXTENDPRAUTO}"
SRC_URI = " \
git://git.multitech.net/mtac-pulse.git;protocol=git;branch=master \
diff --git a/recipes-bsp/multitech/mtac-xdot_1.1.1.bb b/recipes-bsp/multitech/mtac-xdot_1.1.1.bb
index c03250e..fb2c33a 100644
--- a/recipes-bsp/multitech/mtac-xdot_1.1.1.bb
+++ b/recipes-bsp/multitech/mtac-xdot_1.1.1.bb
@@ -12,7 +12,9 @@ COMPATIBLE_MACHINE = "(mtcdt|mtcpmhs)"
SRCREV = "${PV}"
-PR = "${INC_PR}.1${KERNEL_MODULE_PACKAGE_SUFFIX}"
+PR = "${INC_PR}.1"
+
+PKGR = "${PR}${KERNEL_MODULE_PACKAGE_SUFFIX}${EXTENDPRAUTO}"
SRC_URI = " \
git://git.multitech.net/mtac-xdot.git;protocol=git;branch=master \
diff --git a/recipes-bsp/multitech/mtac_4.0.7.bb b/recipes-bsp/multitech/mtac_4.0.7.bb
index caf1092..ebe091a 100644
--- a/recipes-bsp/multitech/mtac_4.0.7.bb
+++ b/recipes-bsp/multitech/mtac_4.0.7.bb
@@ -17,7 +17,9 @@ SRCREV = "${PV}"
# Some packages depend on mtac
RPROVIDES_kernel-module-${PN} = "mtac"
-PR = "${INC_PR}.1${KERNEL_MODULE_PACKAGE_SUFFIX}"
+PR = "${INC_PR}.1"
+
+PKGR = "${PR}${KERNEL_MODULE_PACKAGE_SUFFIX}${EXTENDPRAUTO}"
SRC_URI = " \
git://git.multitech.net/mtac.git;protocol=git;branch=master \
diff --git a/recipes-bsp/multitech/mts-io.inc b/recipes-bsp/multitech/mts-io.inc
index 7aee110..1aa6f02 100644
--- a/recipes-bsp/multitech/mts-io.inc
+++ b/recipes-bsp/multitech/mts-io.inc
@@ -10,7 +10,8 @@ do_fetch[depends] += "virtual/kernel:do_shared_workdir"
INC_PR = "r4"
SRCREV = "${PV}"
-PR = "${INC_PR}.0-${KERNEL_MODULE_PACKAGE_SUFFIX}"
+PR = "${INC_PR}.0"
+PKGR = "${PR}-${KERNEL_MODULE_PACKAGE_SUFFIX}${EXTENDPRAUTO}"
# Some package needs to provide mts-io
RPROVIDES_kernel-module-${PN} = "mts-io"