summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2021-10-07 10:38:38 -0500
committerAndrii Pientsov <andrii.pientsov@globallogic.com>2021-11-18 14:14:26 +0200
commit8258480e0f4703063cb083cec3bbd2e80ea3bcab (patch)
tree89d2d380da8e94f24b82d820d8ef22614da8dcd4
parent5e9f89a26acb0ae3e8affafd1c3a01f5e02887a5 (diff)
downloadmeta-multitech-8258480e0f4703063cb083cec3bbd2e80ea3bcab.tar.gz
meta-multitech-8258480e0f4703063cb083cec3bbd2e80ea3bcab.tar.bz2
meta-multitech-8258480e0f4703063cb083cec3bbd2e80ea3bcab.zip
Development patch for MTCDT-0.2 mts-io for MTAC-MFSER
-rw-r--r--recipes-bsp/multitech/mtac/serial-enable-tx-enable.patch49
-rw-r--r--recipes-bsp/multitech/mtac_4.0.9.bb2
2 files changed, 50 insertions, 1 deletions
diff --git a/recipes-bsp/multitech/mtac/serial-enable-tx-enable.patch b/recipes-bsp/multitech/mtac/serial-enable-tx-enable.patch
new file mode 100644
index 0000000..095c518
--- /dev/null
+++ b/recipes-bsp/multitech/mtac/serial-enable-tx-enable.patch
@@ -0,0 +1,49 @@
+diff --git a/configure.ac b/configure.ac
+index 8e49919..6855328 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1,4 +1,4 @@
+-AC_INIT([mtac], [4.0.6])
++AC_INIT([mtac], [4.0.8])
+ AM_INIT_AUTOMAKE
+ AM_CONFIG_HEADER([config.h])
+
+diff --git a/machine/sam9g25_gpio.h b/machine/sam9g25_gpio.h
+index 3848576..eaeb42b 100644
+--- a/machine/sam9g25_gpio.h
++++ b/machine/sam9g25_gpio.h
+@@ -22,4 +22,9 @@
+ #define M_AP2_NRESET AT91_PIN_PB13
+ #define M_AP2_NINT1 AT91_PIN_PB17
+ #define M_AP2_NINT2 AT91_PIN_PB18
++
++// Special control pins for serial interface
++#define M_AP1_ENABLE_TX_ENABLE AT91_PIN_PC31
++#define M_AP2_ENABLE_TX_ENABLE AT91_PIN_PC30
++
+ #endif /* SAM9G25_MFSER_GPIO_H */
+diff --git a/machine/ti43x_gpio.h b/machine/ti43x_gpio.h
+index 734998d..3f27e95 100644
+--- a/machine/ti43x_gpio.h
++++ b/machine/ti43x_gpio.h
+@@ -22,4 +22,10 @@
+ #define M_AP2_NRESET OMAP_GPIO(5,29)
+ #define M_AP2_NINT1 OMAP_GPIO(3,17)
+ #define M_AP2_NINT2 OMAP_GPIO(3,18)
++
++// Special control pins for serial interface
++// which don't exist on the TI platform.
++#define M_AP1_ENABLE_TX_ENABLE 0
++#define M_AP2_ENABLE_TX_ENABLE 0
++
+ #endif /* TI MTCDT3-BB */
+diff --git a/mtac.c b/mtac.c
+index 2fefc0e..b7b59cd 100644
+--- a/mtac.c
++++ b/mtac.c
+@@ -1,4 +1,4 @@
+-#define DRIVER_VERSION "v4.0.5"
++#define DRIVER_VERSION "v4.0.8"
+ #define DRIVER_AUTHOR "Multi-Tech"
+ #define DRIVER_DESC "MTS driver to supervise MTAC slots"
+ #define DRIVER_NAME "mtac-slots"
diff --git a/recipes-bsp/multitech/mtac_4.0.9.bb b/recipes-bsp/multitech/mtac_4.0.9.bb
index ecabcb3..0327ebf 100644
--- a/recipes-bsp/multitech/mtac_4.0.9.bb
+++ b/recipes-bsp/multitech/mtac_4.0.9.bb
@@ -6,7 +6,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
do_fetch[depends]+="virtual/kernel:do_shared_workdir"
DEPENDS = "virtual/kernel mts-io"
-INC_PR = "r0"
+INC_PR = "r1"
COMPATIBLE_MACHINE = "(mtcdt|mtcpmhs)"
SRCREV = "${AUTOREV}"